perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Gunton <n...@nilspace.com>
Subject Possible bug in Embperl 2.3
Date Thu, 24 Jul 2008 18:53:08 GMT
I am getting segmentation faults from Apache2.2, mod_perl 2, Embperl 
2.3, when I have a [$ sub $] redefined for an Embperl::Object setup and 
then attempt to call the parent version of the sub. For example, I have 
[$ sub xxx $] in one of the base libs, and then I call 
$self->SUPER::xxx() from within the version of xxx() which is in the 
subdir. This worked fine in Embperl 1.3.6.

Should we be able to call SUPER::xxx from inside [$ sub $] routines? I 
know it works fine for perl subs, but maybe [$ sub $] is handled 
differently in Embperl 2.x.

I don't know if this matters, but xxx() is only defined in the very 
base-most file, then redefined several dir levels above that. In other 
words we have something like:

/www/lib/perl/Apache/Utils.epl:
[$ sub xxx $]
[$ endsub $]

htdocs/Core.epl:
[! Execute ({isa => '/www/lib/perl/Apache/Utils.epl'}) !]

htdocs/website/Core.epl:
Execute ({isa => '../Core.epl'});

htdocs/website/contact/Core.epl:
Execute ({isa => '../Core.epl'});
[$ sub xxx $]
[-
($self) = @_;
$self->SUPER::xxx()
-]
[$ endsub $]

Neil

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message