perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neil Gunton <n...@nilspace.com>
Subject Re: Problem using Embperl on Debian Lenny
Date Mon, 14 Jul 2008 17:50:58 GMT
Can anybody please lend any insights here (see below)? Is anybody 
actually using the stock Embperl2 that comes with Debian Lenny 
(testing), along with stock Apache2 and mod_perl2? Are there problems 
with it, or am I just doing something stupid with my configuration? The 
error seems to imply that there may be something out of sync between 
Embperl and the Apache2.2 API, but it could also just be a symptom of 
something I'm doing wrong. Right now I am out of ideas.

I don't mean to be pushy, but I am going up to my datacenter in Chicago 
on Wednesday (round trip takes all day) to rebuild my server. I'd like 
to find out as soon as possible before then whether it's going to be 
possible to install Debian Lenny, with all its latest software, or if 
I'll instead have to stay with Etch. I'd much rather go to Lenny, but if 
there are intrinsic problems with the Debian packages of Embperl then 
I'll have to rethink.

Any help would be *much* appreciated...

Thanks!

Neil

Neil Gunton wrote:
> Hi, I've been using Embperl 1.3 for years now on Apache 1.3, and now I'm 
> finally trying to upgrade my websites to use the latest Embperl which is 
> included with Debian Lenny (testing). So that means Apache 2.2, mod_perl 
>  2, Embperl 2.2... I am just installing all this from the deb packages, 
> not from source.
> 
> I'm having a problem getting Embperl 2.2.0 to run. I have a very simple 
> config set up in /etc/apache2/mods-available/zembperl.conf:
> 
> PerlModule Embperl
> EMBPERL_OBJECT_BASE base.epl
> <FilesMatch ".*\.html$">
>     SetHandler  perl-script
>     PerlHandler Embperl::Object
>     Options     ExecCGI
> </FilesMatch>
> 
> The zembperl.load is left unchanged.
> 
> In /etc/apache2/sites-available/dev.neilgunton.com I have:
> NameVirtualHost dev.neilgunton.com
> <VirtualHost dev.neilgunton.com>
>     ServerName dev.neilgunton.com
>     ServerAlias *.dev.neilgunton.com
>     DocumentRoot /www-dev/vhosts/test
>     PerlSetEnv EMBPERL_APPNAME neilgunton_dev
> </VirtualHost>
> 
> When I try to access dev.neilgunton.com, I get 500 error, with this in 
> the log:
> 
> ERR:  24:  Error in Perl code: Can't call method "component" on an 
> undefined value at /usr/lib/perl5/Embperl/App.pm line 58.\n
> ERR:  61: : Unknown recipe 'Embperl'
> Can't call method "log_file_start_pos" on an undefined value at 
> /usr/lib/perl5/Embperl/App.pm line 81.
> 
> Any clues on what I'm doing wrong here?
> 
> Thanks!
> 
> Neil
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message