perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter - ECOS GmbH" <rich...@ecos.de>
Subject RE: Re: Re: Re: Process exists - Segmentation fault
Date Wed, 09 Jan 2008 13:56:30 GMT
Hi,

Maybe we should go one step back:

Does "make test" works correctly for you?

Does it also test the mod_perl part?

Gerald
 

> -----Original Message-----
> From: abhishek jain [mailto:mail@ejain.com] 
> Sent: Monday, January 07, 2008 2:59 AM
> To: Gerald Richter
> Cc: modperl@perl.apache.org
> Subject: Re: Re: Re: Process exists - Segmentation fault
> 
> Hi Its me again,
> But still the things are not working right.
> I tried to recompile Embperl and put PerlModule Embperl after 
> LoadModule embperl_module ..............
>  
> Now i do not remember it was before or now but after i 
> uncomment the 'PerlModule Embperl' line and things stop 
> working i do not receieve $r=shift; variable i mean $r = undef here.
> Is it due to something i did during installation of embperl.
> Also If i uncomment the line 'MaxRequestsPerChild 1' and 
> comment 'PerlModule Embperl ' then i recveive this line in 
> error log [Sun Jan 06 18:44:11 2008] [notice] child pid 30280 
> exit signal Segmentation fault (11)
>  
> (May be error and page refreshes itself i mean the code 
> produces output.)
>  
> and page appears , sometimes the same error appears twice and 
> page does not appears.
>  
> I am not sure have this error been encountered by someone 
> else but things are not working right for me . Also if 
> someone wants i can mail the Embperl logs to someone 
> individually, i do not want to make the logs public. 
> Pl help. I am working on the site http://delhi.pm.org/ it is 
> the delhi perl mongers site and people in this group have 
> limited knowledge of embperl but this will push up the 
> embperl in Delhi . 
> --
> Thanks
> Abhishek jain
> 
>  
> On 1/4/08, Gerald Richter - ECOS GmbH <richter@ecos.de> wrote: 
> 
> 	Hi,
> 	
> 	Not sure if it makes any difference, but the lines
> 	
> 	LoadModule  embperl_module
> 	
> /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Em
> bperl/Embp 
> 	erl.so
> 	PerlModule Apache::DBI
> 	PerlModule Embperl
> 	
> 	Should be outside of the VirtualHost block (they are 
> global anyway)
> 	
> 	The other thing that you should make sure, is that 
> mod_perl is compiled
> 	with the same Perl that Embperl is and both are using 
> modules from the 
> 	path /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
> 	
> 	If there is any version mismatch, things cannot run correctly.
> 	
> 	Gerald
> 	
> 	
> 	> -----Original Message-----
> 	> From: abhishek jain [mailto: mail@ejain.com]
> 	> Sent: Thursday, January 03, 2008 8:20 PM
> 	> To: Gerald Richter
> 	> Cc: modperl@perl.apache.org
> 	> Subject: Re: Re: Process exists - Segmentation fault 
> 	>
> 	> Hi,
> 	> Adding PerlModule Embperl did not solved the problem , infact
> 	> it aggreviated it. With this the page is not didsplaye at all.
> 	> My apache configuration is:
> 	>
> 	> <VirtualHost <ip>:80> 
> 	> SuexecUserGroup "#<id>" "#<id>"
> 	> ServerName xxxxxxxxxxxxxxxxx
> 	> ServerAlias www.xxxxxxxxxxxxxxxxx
> 	> DocumentRoot <public_html>
> 	> ErrorLog <dir>/logs/error_log 
> 	> CustomLog <dir>/logs/access_log combined
> 	> LoadModule  embperl_module
> 	> /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Em
> 	bperl/Embperl.so
> 	> PerlModule Apache::DBI
> 	> PerlModule Embperl 
> 	> <Directory <public_html dir>>
> 	> Options Indexes IncludesNOEXEC FollowSymLinks
> 	> allow from all
> 	> AllowOverride All
> 	>
> 	> <FilesMatch "^<file_name>$">
> 	>                         SetHandler  perl-script
> 	>                         PerlHandler Embperl::Object
> 	>                         Options     ExecCGI
> 	>                 </FilesMatch>
> 	>  <FilesMatch ".*\.epl$"> 
> 	>                         Order allow,deny
> 	>                         Deny From all
> 	>                 </FilesMatch>
> 	>  <FilesMatch ".*\.pl$">
> 	>                         Order allow,deny 
> 	>                         Deny From all
> 	>                 </FilesMatch>
> 	>
> 	>
> 	> </Directory>
> 	> <Directory <cgi_dir>>
> 	> allow from all
> 	> </Directory> 
> 	>                 PerlSetEnv EMBPERL_ESCMODE 0
> 	>                 PerlSetEnv EMBPERL_OPTIONS 16
> 	>                 PerlSetEnv EMBPERL_MAILHOST <host>
> 	>                 PerlSetEnv EMBPERL_OBJECT_BASE _base.epl 
> 	>                 PerlSetEnv EMBPERL_OBJECT_FALLBACK 
> notfound.html
> 	>                 PerlSetEnv EMBPERL_DEBUG 0
> 	>                 PerlSetEnv EMBPERL_OBJECT_APP epwebapp.pl
> 	> </VirtualHost>
> 	>
> 	>
> 	> Thanks,
> 	> Abhishek jain
> 	>
> 	>
> 	> On 1/3/08, Gerald Richter - ECOS GmbH <richter@ecos.de> wrote:
> 	>
> 	>       Please add a
> 	> 
> 	>       PerlModule Embperl
> 	>
> 	>       Somewhere _after_ the LoadModule
> 	>
> 	>       Gerald
> 	>
> 	>
> 	>       > -----Original Message-----
> 	>       > From: abhishek jain [mailto: mail@ejain.com]
> 	>       > Sent: Thursday, January 03, 2008 12:53 PM
> 	>       > To: Gerald Richter
> 	>       > Cc: modperl@perl.apache.org 
> 	>       > Subject: Re: Process exists - Segmentation fault
> 	>       >
> 	>       > Hi,
> 	>       > I have the following statement in my httpd.conf
> 	>       >
> 	>       > LoadModule  embperl_module 
> 	>       >
> 	> /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Em
> 	>       > bperl/Embperl.so
> 	>       >
> 	>       > I do not have a related PerlModule just one 
> for Apache::DBI . 
> 	>       > Thanks,
> 	>       > Abhishek jain
> 	>       >
> 	>       > On 1/3/08, Gerald Richter - ECOS GmbH <
> 	> richter@ecos.de <mailto: richter@ecos.de 
> <mailto:richter@ecos.de> > > wrote:
> 	>       >
> 	>       >       Hi,
> 	>       >
> 	>       >       Apache with mod_perl will always have 
> this size or even
> 	>       > more. This is
> 	>       >       ok. 
> 	>       >
> 	>       >       ulimit -a shows the process limits, but 
> should normaly
> 	>       > not a problem
> 	>       >
> 	>       >       The behaviour you describe occurs when 
> you do _not_ 
> 	>       > have a LoadModule
> 	>       >       _and_ a PerlModule statement for Embperl in
> 	> your httpd.conf
> 	>       >
> 	>       >       Gerald
> 	>       >
> 	>       >
> 	>       >       > -----Original Message-----
> 	>       >       > From: abhishek jain [mailto: mail@ejain.com]
> 	>       >       > Sent: Thursday, January 03, 2008 4:59 AM 
> 	>       >       > To: modperl@perl.apache.org
> 	>       >       > Subject: Process exists - Segmentation fault
> 	>       >       >
> 	>       >       > Hi, 
> 	>       >       > I am running modperl 2.x + embperl on centos
> 	> 4.5 Now when i
> 	>       >       > run on MaxRequestsPerChild 1 the app. runs
> 	> well but as i
> 	>       >       > increase its value after every third refresh 
> 	> of browser a
> 	>       >       > blank page appears, also the process size
> 	> exceeds probably to
> 	>       >       > 19M , and in error_log segmentation fault
> 	> error appears.
> 	>       >       > I believe the size exceeds some threshold. 
> 	>       >       > Now is there a way to increase the value of
> 	>       > MaxRequestsPerChild ?
> 	>       >       > Can i increase the threshold value of 
> size of a
> 	>       > process or so ? 
> 	>       >       > Thanks,
> 	>       >       > Abhishek jain
> 	>       >       >
> 	>       >       >
> 	>       >       >
> 	>       >
> 	>       >       ** Virus checked by BB-5000 Mailfilter ** 
> 	>       >
> 	>       >
> 	>       >
> 	>       >
> 	>
> 	>       ** Virus checked by BB-5000 Mailfilter **
> 	>
> 	>
> 	>
> 	>
> 	
> 	** Virus checked by BB-5000 Mailfilter ** 
> 	
> 
> 
> 

** Virus checked by BB-5000 Mailfilter **

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message