perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim_Gr...@vwr.com
Subject RE: Embperl logging "out of control"
Date Wed, 12 Dec 2007 22:11:01 GMT


Thanks to everyone for the replies. I'll get to them all, but I can answer
Sherman Culler's questions now.

>Just curious - why not upgrade Apache/Embperl/mod_perl to the latest
>versions - Apache 2.x, Embperl 2.x and mod_perl 2?

We tried this a while ago. Embperl 2 is stricter with its HTML validation
and Perl syntax than version 1, and this caused a lot of headaches with our
legacy code. The project was killed.

>>Do you use virtualhost directives?

We do, but only for our some environments. We first noticed the problem on
machines that don't use them.

>>I need some more information about how your server is setup.

What do you need?

>>Have you read the documentation at
http://perl.apache.org/embperl/pod/doc/doc13/HTML/Embperl.-page-4-.htm ?

Yes.

>>Why do you use PerlSetEnv for the first line and then SetEnv for the
following lines?

I don't have an answer, as I didn't write that code. All of these are
global settings, not per directory, so it would seem SetEnv would be fine
for all. But my jimmying things around didn't fix anything, so I provided
the code I inherited.

--
Regards,
Tim Grant
Application Developer, VWR International
610-719-7097


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message