perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter - ECOS GmbH" <rich...@ecos.de>
Subject RE: html::embperl is not supported?
Date Thu, 04 Oct 2007 09:44:59 GMT
Hi,

Embperl 1.3.x is not supported anymore and will not work with Apache 2.x

You need to upgrade to Embperl 2.3. Please make sure to read the hints 
in README.v2

Gerald

P.S. For further questions, please us the Embperl mailing list

------------------------------------------------------------------------
Besuchen Sie unseren Messestand auf der SYSTEMS vom 23. - 26.10. in
München, Halle B3, Stand 425 www.ecos.de/messen-events/systems-2007.html
------------------------------------------------------------------------
Gerald Richter       ECOS electronic communication services GmbH
*******************  SECURING YOUR NETWORK  ********************

Post:       Tulpenstrasse 5            D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de            Voice:   +49 6133 939-122
WWW:        http://www.ecos.de         Fax:     +49 6133 939-333

Sitz der Gesellschaft: Dienheim; AG Mainz HRB 6889; GF: W.Heck,G.Richter
------------------------------------------------------------------------
 
  

> -----Original Message-----
> From: Pavel Taranov [mailto:tarantul@tarhost.ru] 
> Sent: Wednesday, October 03, 2007 1:19 AM
> To: Gerald Richter
> Subject: html::embperl is not supported?
> 
> Guten Tag Gerald!
> I developer from Russia.
> I use HTML::Embperl in the my projects.
> I update with apache 1.3 with mod_perl 1.3 to apache 2.2 with 
> mod_perl2, but your module don't make.
> Please help me! Excuse me for my bad English.
> 
> Listing:
> [HTML-Embperl-1.3.6]# uname -a
> Linux tarhost.ru 2.6.17-1.2142_FC4 #1 Tue Jul 11 22:41:14 EDT 
> 2006 i686 i686 i386 GNU/Linux
> 
> [HTML-Embperl-1.3.6]# perl Makefile.PL
> Build with support for Apache mod_perl?(y/n) [y] Use 
> /usr1/home/tarantul/src/httpd-2.2.6 as Apache
> source(y/n) [y]
> Will use /usr1/home/tarantul/src/httpd-2.2.6 for Apache 
> Headers Enter path and file to start as httpd 
> [/usr1/home/tarantul/src/httpd-2.2.6/httpd]/usr/local/httpd/bin/httpd
> Apache Version Server version: Apache/2.2.6 (Unix)
>   + found mod_ssl
> Syntax error on line 1 of
> /usr1/home/tarantul/src/HTML-Embperl-1.3.6/test/conf/ssldisable.conf:
> Invalid command 'SSLDisable', perhaps misspelled or defined 
> by a module not included in the server configuration Test 
> start /usr/local/httpd/bin/httpd Test httpd will run as user 
> nobody and group root Test httpd will listen on port 8531 
> Found mod_perl  Version 1.30 Found LWP::UserAgent  Version 
> 2.033 Found HTML::HeadParser  Version 2.21 Apache::Session 
> not installed on this system
> -> Disable tests for persistent data storage
> Found File::Spec  Version 3.24
> Found CGI  Version 3.10
> Writing Makefile for HTML::Embperl
> 
> Why mod_perl  Version 1.30?
> I build with apache mod_perl-2.0.3!
> 
> [HTML-Embperl-1.3.6]# make
> Skip blib/lib/HTML/Embperl.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/CVS.pod (unchanged) Skip 
> blib/lib/HTML/epocgi.test.pl (unchanged) Skip 
> blib/lib/HTML/Embperl/IntroEmbperlObject.pod
> (unchanged)
> Skip blib/lib/HTML/epocgi.pl (unchanged) Skip 
> blib/lib/HTML/embpcgi.test.pl (unchanged) Skip 
> blib/lib/HTML/Embperl/Faq.pod (unchanged) Skip 
> blib/lib/HTML/embpcgi.pl (unchanged) Skip 
> blib/lib/HTML/Embperl/Module.pm (unchanged) Skip 
> blib/lib/HTML/embpexec.pl (unchanged) Skip 
> blib/lib/HTML/Embperl/Session.pm (unchanged) Skip 
> blib/lib/HTML/Embperl/INSTALL.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/FeaturesD.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/Changes.pod (unchanged) Skip 
> blib/lib/HTML/Embperl.pm (unchanged) Skip 
> blib/lib/HTML/Embperl/NEWS.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/Intro.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/IntroD.pod (unchanged) Skip 
> blib/lib/HTML/embpfastcgi.pl (unchanged) Skip 
> blib/lib/HTML/EmbperlD.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/Features.pod (unchanged) Skip 
> blib/lib/HTML/Embperl/TipsAndTricks.pod (unchanged) Skip 
> blib/lib/HTML/EmbperlObject.pm (unchanged) Skip 
> blib/lib/HTML/Embperl/Mail.pm (unchanged) /usr/bin/perl 
> /usr/lib/perl5/5.8.6/ExtUtils/xsubpp
>  -typemap /usr/lib/perl5/5.8.6/ExtUtils/typemap -typemap 
> typemap  Embperl.xs > Embperl.xsc && mv Embperl.xsc Embperl.c 
> gcc -c  -I/usr1/home/tarantul/src/httpd-2.2.6/include
> -I/usr1/home/tarantul/src/httpd-2.2.6/regex
> -I/usr1/home/tarantul/src/httpd-2.2.6/os/unix
> -I/usr1/home/tarantul/src/HTML-Embperl-1.3.6/xs
> -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING
> -fno-strict-aliasing -pipe -I/usr/local/include 
> -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 
> -I/usr/include/gdbm -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 
> -fexceptions -m32 -march=i386 -mtune=pentium4 
> -fasynchronous-unwind-tables   -DVERSION=\"1.3.6\" 
> -DXS_VERSION=\"1.3.6\" -fPIC
> "-I/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE" 
>  -DAPACHE  -o Embperl.o Embperl.c
> gcc -c  -I/usr1/home/tarantul/src/httpd-2.2.6/include
> -I/usr1/home/tarantul/src/httpd-2.2.6/regex
> -I/usr1/home/tarantul/src/httpd-2.2.6/os/unix
> -I/usr1/home/tarantul/src/HTML-Embperl-1.3.6/xs
> -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING
> -fno-strict-aliasing -pipe -I/usr/local/include 
> -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 
> -I/usr/include/gdbm -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 
> -fexceptions -m32 -march=i386 -mtune=pentium4 
> -fasynchronous-unwind-tables   -DVERSION=\"1.3.6\" 
> -DXS_VERSION=\"1.3.6\" -fPIC
> "-I/usr/lib/perl5/5.8.6/i386-linux-thread-multi/CORE" 
>  -DAPACHE  -o epmain.o epmain.c
> epmain.c: In function 'GetInputData_CGIScript':
> epmain.c:707: error: 'array_header' undeclared (first use in 
> this function)
> epmain.c:707: error: (Each undeclared identifier is reported only once
> epmain.c:707: error: for each function it appears in.)
> epmain.c:707: error: 'hdrs_arr' undeclared (first use in this 
> function)
> epmain.c:708: error: 'table_entry' undeclared (first use in 
> this function)
> epmain.c:708: error: 'hdrs' undeclared (first use in this
> function)
> epmain.c:711: error: syntax error before ')' token
> epmain.c:743: warning: initialization makes pointer from 
> integer without a cast
> epmain.c: In function 'EMBPERL_SetupFileData':
> epmain.c:1940: warning: ignoring return value of 'getcwd', 
> declared with attribute warn_unused_result
> epmain.c: In function 'EMBPERL_GetFileData':
> epmain.c:2070: warning: ignoring return value of 'getcwd', 
> declared with attribute warn_unused_result
> epmain.c: In function 'EndOutput':
> epmain.c:2905: warning: assignment makes pointer from integer 
> without a cast
> epmain.c:2958: error: 'array_header' undeclared (first use in 
> this function)
> epmain.c:2958: error: 'hdrs_arr' undeclared (first use in 
> this function)
> epmain.c:2959: error: 'table_entry' undeclared (first use in 
> this function)
> epmain.c:2959: error: 'hdrs' undeclared (first use in this
> function)
> epmain.c:2962: error: syntax error before ')' token
> epmain.c: In function 'EMBPERL_ExecuteReq':
> epmain.c:3781: warning: ignoring return value of 'getcwd', 
> declared with attribute warn_unused_result
> epmain.c:3813: warning: ignoring return value of 'chdir', 
> declared with attribute warn_unused_result
> make: *** [epmain.o] Ошибка 1
> 
> Warum?
> 
> 
> 
> ---
> Best Regards,
> Pavel Taranov,
> http://www.tarhost.ru
> http://tarantul.net.ru
> 
> ** Virus checked by BB-5000 Mailfilter ** 
> !DSPAM:416,4702d7a2178839207114891!
> 
> 

** Virus checked by BB-5000 Mailfilter **

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message