perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Kyncl <ky...@pcv.cz>
Subject Re: WORKING!!!!!
Date Sun, 30 Sep 2007 20:29:38 GMT
Hi all,
for GENTOO users

combination:
Apache 2.2.6.
Mod_perl/2.0.3
Perl/v5.8.8
Embperl 2.3.0

is working !!!!

There were several problems:

1) It  was neccessary re-emerge libperl before emerging modperl
/ACCEPT_KEYWORDS="~amd64"  emerge   libperl _ _/_for the intel procesor 
use ~x86
_/ACCEPT_KEYWORDS="~amd64"  emerge   modperl _ _/_for the intel procesor 
use ~x86_
2) There is no fresh ebuild for the Embperl so solution is rename 
existing Embperl-2.0_rc4.ebuild  to  Embperl-2.3.0.ebuild
after that use this command :
/ebuild Embperl-2.3.0.ebuild digest/
and emerge Embperl, I'm not using Xalan therefore there is use option -xalan
/ACCEPT_KEYWORDS="~amd64" USE="modperl -xalan" emerge  Embperl /_ for 
the intel procesor use ~x86_
in /etc/conf.d/apache2 set/ APACHE2_OPTS="-D PERL -D EMBPERL"
/all others config as usual.


So I hope that It will help somebody, btw: I'm not Gentoo guru so maybe 
somobody will find more elegant solution.

Best Regards

Jan Kyncl


Mime
View raw message