perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruben Safir <ru...@mrbrklyn.com>
Subject Debugging behavior
Date Tue, 29 May 2007 01:56:24 GMT

I'm not getting excepted behavior from the debugging in the embperl site I have built with


Embperl/2.0rc4 Apache/2.0.54 (Unix) mod_perl/2.0.0 Perl/v5.8.5 

I used to get STDERR to print to /usr/local/apache/logs/error_logs

and a breakdown of EMBPERLS steps in /tmp/embperl.log

I've tried numerous variations of this


LoadModule perl_module modules/mod_perl.so
LoadModule  embperl_module  "/usr/lib/perl5/site_perl/5.8.5/i586-linux-thread-multi/auto/Embperl/Embperl.so"

PerlModule Embperl
#EMBPERL_DEBUG 255
#EMBPERL_VIRTLOG /embperl/log
EMBPERL_LOG /tmp/embperl.log
#SetEnv EMBPERL_DEBUG 2147475453
EMBPERL_DEBUG 262399
Embperl_UseEnv        on


in the httpd.conf

if I use EMBPERL_DEBUG 2147475453 I get way too much noise to be useful

if I use anything else I only get this in the logs

[18669]REQ: ***** Start Request at Mon May 28 21:12:45 2007
[18669]Use App: Embperl
[18669]HDR:  9
[18669]HDR:  Host=www.nylxs.com
[18669]HDR:  User-Agent=Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920
Firefox/1.0.7 SUSE/1.0.7-0.1
[18669]HDR:  Accept=text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
[18669]HDR:  Accept-Language=en-us,en;q=0.5
[18669]HDR:  Accept-Encoding=gzip,deflate
[18669]HDR:  Accept-Charset=ISO-8859-1,utf-8;q=0.7,*;q=0.7
[18669]HDR:  Keep-Alive=300
[18669]HDR:  Connection=keep-alive
[18669]HDR:  Cache-Control=max-age=0
[18669]ENV:  MOD_PERL_API_VERSION=2
[18669]ENV:  MOD_PERL=mod_perl/2.0.0
[18669]Formdata... length = 0
[18669]Using APACHE for output...
[18670] Use Recipe Embperl
[18669]EVAL< <unknown>
[18669]SVs:  14189
[18669]EVAL> <undefined>
[18669]PERF: Run Start Time: 0 ms
[18669]PERF: Run End Time:   0 ms
[18669]PERF: Run Time:       0 ms
[18669]PERF: DOMSTAT: MemUsage = 88516 Bytes  numNodes = 790  numLevelLookup = 0  numLevelLookupItem
= 0  numStr = 274  numReplace = 3
[18669]HDR:  0
[18669]PERF: input = ???
[18669]PERF: Time: 0 ms
[18669]Request finished. Mon May 28 21:12:45 2007
. Entry-SVs: 14149  Exit-SVs: 14168
[18669]PERF: DOMSTAT: MemUsage = 77428 Bytes  numNodes = 789  numLevelLookup = 0  numLevelLookupItem
= 0  numStr = 273  numReplace = 3


Which is virturaly useless...


Then when I use [- print STDERR "KICK ME" -]

I get no printing to /usr/local/apache/log/error_file_for_the_virtual_server_or_the_mane_server_log


I've used EMBPERL for years and this is really driving me nuts.

Ruben


-- 
http://www.mrbrklyn.com - Interesting Stuff
http://www.nylxs.com - Leadership Development in Free Software

So many immigrant groups have swept through our town that Brooklyn, like Atlantis, reaches
mythological proportions in the mind of the world  - RI Safir 1998

http://fairuse.nylxs.com  DRM is THEFT - We are the STAKEHOLDERS - RI Safir 2002

"Yeah - I write Free Software...so SUE ME"

"The tremendous problem we face is that we are becoming sharecroppers to our own cultural
heritage -- we need the ability to participate in our own society."

"> I'm an engineer. I choose the best tool for the job, politics be damned.<
You must be a stupid engineer then, because politcs and technology have been attacted at the
hip since the 1st dynasty in Ancient Egypt.  I guess you missed that one."

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message