perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gunnar Wolf <gw...@gwolf.org>
Subject Re: $escmode behaving inconsistently?
Date Mon, 02 Apr 2007 15:59:34 GMT
Gerald Richter - ECOS GmbH dijo [Mon, Apr 02, 2007 at 04:05:22PM +0200]:
> Could you send your complete configuration regarding Embperl from your 
> httpd.conf?
> 
> Gerald

Of course. First of all, the
/etc/apache2/mods-available/zembperl.{conf,load} files are IIRC the
stock ones shipped with Debian: 

-zembperl.conf--------------------------------------------------------
# The sucky "zembperl" name is so we load after perl

AddType text/html .epl

<IfModule mod_perl.c>
  # mod_perl version

  PerlModule Embperl

  <Files *.epl>
    SetHandler perl-script
    PerlHandler Embperl
    Options ExecCGI
  </Files>
</IfModule>

<IfModule !mod_perl.c>
  # CGI version

  <IfModule mod_actions.c>
    Action embperl /cgi-bin/embpcgi.pl
    Action embperlobject /cgi-bin/epocgi.pl
    Action embperl-fastcgi /cgi-bin/embpfastcgi.pl

    AddHandler embperl .epl
  </IfModule>
</IfModule>
----------------------------------------------------------------------

-zembperl.load--------------------------------------------------------
# The sucky "zembperl" name is so we load after perl

<IfModule mod_perl.c>
  LoadModule embperl_module /usr/lib/perl5/auto/Embperl/Embperl.so
</IfModule>
----------------------------------------------------------------------

Now, regarding my app: It is a bit dirty (this means, I've tried a
couple options which are duplicated), this is strictly from my
development machine:

-comas.conf-----------------------------------------------------------
<IfModule mod_perl.c>
    Alias /comas /home/gwolf/cvs/comas/trunk/embperl

    PerlSetEnv EMBPERL_ESCMODE 0
    PerlSetEnv EMBPERL_OPTIONS 16
    PerlSetEnv EMBPERL_MAILHOST mosca.iiec.unam.mx
    PerlSetEnv EMBPERL_DEBUG 0
    <Location /comas>
        EMBPERL_INPUT_ESCMODE 0
	EMBPERL_OBJECT_APP base.pm
	EMBPERL_APPNAME comas
	EMBPERL_OBJECT_FALLBACK index.html
	EMBPERL_TOP_INCLUDE "use strict;"
	SetHandler perl-script
	PerlHandler Embperl::Object
	Options ExecCGI
    </Location>

    <FilesMatch "\.epl$|\.pm$">
        Order allow,deny
	Deny From all
    </FilesMatch>
</IfModule>
----------------------------------------------------------------------

Besides this, and besides loading mod_perl (tell me if that part of
the configuration might be useful), I'm only loading Apache::DBI and
adding /home/gwolf/cvs/comas/trunk/lib at startup, from mod_perl's
configuration. 

You might remember some months ago I bothered you for another problem,
regarding just a noisy exit() function - I had to temporarily leave
this project, so I didn't look into it any further... I'll bug you
again with that as well :)

This machine is running Debian Sid (unstable), with the following
versions:

apache2-mpm-prefork                 2.2.3-4
libapache2-mod-perl2                2.0.2-2.4
libembperl-perl                     2.2.0-1.2

Greetings,

-- 
Gunnar Wolf - gwolf@gwolf.org - (+52-55)5623-0154 / 1451-2244
PGP key 1024D/8BB527AF 2001-10-23
Fingerprint: 0C79 D2D1 2C4E 9CE4 5973  F800 D80E F35A 8BB5 27AF

Mime
View raw message