perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kolikov <koli...@free.fr>
Subject Debian testing libapache2-mod-perl2 (2.0.2-2.2) and libembperl-perl(2.2.0-1)
Date Wed, 08 Nov 2006 18:02:14 GMT
Hi,

Note:
mail already sent to : modperl@perl.apache.org

This question is not directly linked with embperl but
embperl is said to be supporting mod-perl with version
 >= to 1.99.14-4

But ...

On a fresh install of libembperl-perl(2.2.0-1)
with libapache2-mod-perl2 (2.0.2-2.2)
on Debian testing

I get this message :
----------------------
Syntax error on line 185 of /etc/apache2/apache2.conf: Syntax error on
line 4 of /etc/apache2/mods-enabled/zembperl.load: API module structure
`embperl_module' in file /usr/lib/perl5/auto/Embperl/Embperl.so is
garbled - perhaps this is not an Apache module DSO?
----------------------

The '.load' and '.conf' apache2 config files are pointing to the good 
.so module.
As expected : uninstalling mod-perl or embperl makes apache2 run fine.


I am using : Debian GNU/Linux 2.6.17-2-k7 kernel
AND libc6  2.3.6.ds1-4

My installed packages related with apache2 are :
apache2              2.2.3-2
apache2-mpm-prefork  2.2.3-2
apache2-utils        2.2.3-2
libapache2-mod-perl2 2.0.2-2.2


I have already sent a bug report to the libemperl Debian package
maintainer, though i post here to get additional debug help, if possible.


Best Regards
-- 
kolikov@free.fr

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message