perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Rayner" <dray...@savicom.net>
Subject Build of V2.1.0 fails on FreeBSD V6.1
Date Thu, 26 Oct 2006 18:41:41 GMT
I am trying to build Embperl V2.1.0 on:

FreeBSD d0102 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Wed Aug 30 16:36:17 UTC 
2006  amd64

Has anyone successfully built Embperl for this environment?


I have searched through the archives and have found some discussions on this 
subject, and have resolved one problem.  The make on FreeBSD does not seem 
to perform the step of recusive makes in the sub-directories.  I have solved 
this problem by doing a:

    make subdirs

followed by:

    make

The show stopper problem is that the tests fail immediately as follows:

make test
PERL_DL_NONLAZY=0 /usr/local/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl

loading...                    panic: memory wrap at 
/home/drayner/perlbuild/Embperl-2.1.0/blib/lib/Embperl.pm line 108.
Compilation failed in require at test.pl line 1809.
BEGIN failed--compilation aborted at test.pl line 1809.

Test terminated with fatal error
Use of uninitialized value in string ne at test.pl line 1209.
*** Error code 1

Stop in /home/drayner/perlbuild/Embperl-2.1.0.

I know Gerald Richter worked on this problem for a while more than a year 
ago, but from the mail thread in the archive, it was not resolved.  Any 
information beyond that point would be most appreciated.


Thanks and regards,

Doug Rayner
Senior System Architect
Savicom: Next Generation eMail Marketing
http://www.savicom.net
(415) 617-9006



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message