perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Not recognising httpd.conf params
Date Fri, 18 Aug 2006 09:32:56 GMT
Hi,
> 
> I have just installed apache 2.2.3 with Embperl 2.2.0  on OS 
> X 10.4, corrected the issues which fellow users have had and 
> got it to compile.  Now none of the httpd.conf  parameters 
> get used.  

Did you get any error message when you start the httpd?

Does make test succeed?

Gerald


> Example config is as so
> 
> LoadModule perl_module modules/mod_perl.so
> LoadModule embperl_module    
> /opt/local/lib/perl5/site_perl/5.8.8/darwin-2level/auto/Embper
> l/Embperl.so 
> 
> PerlRequire /var/website/scripts/startup_httpd2.pp
> Embperl_Log /tmp/embperl_log
> Embperl_Mail_Errors_Limit 0
> 
> #PerlModule Embperl
> EMBPERL_OBJECT_ADDPATH 
> /var/website/htdocs/library/shared;/var/website/htdocs/library
> <Directory "/var/website/htdocs/library/shared">
>  <Files ~ "\.(html|epl|dxml|shtml)$">
>     EMBPERL_OBJECT_ADDPATH 
> /var/website/htdocs/library/shared;/var/website/htdocs/library
>         Embperl_AppName     ukwl
>         Embperl_Object_Base base.epl
>         Embperl_UriMatch    "\.html.?|\.epl|\.dxml|\.shtml"
>         SetHandler          perl-script
>         PerlHandler         Embperl::Object 
>         Options             ExecCGI
>  </Files>
> </Directory>
> 
> The log file isn't created, the base.epl file is replaced by 
> the default _base.epl... has anyone experienced this or any 
> ideas why ? the same co nfig I have used on various other 
> OS's with no issues ?
> 
> Thanks
> 
> 
> 
> 
> 
> ** Virus checked by BB-5000 Mailfilter ** 
> !DSPAM:44e49a67195241279015795!
> 
> 


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message