perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keven Murphy <murp...@gdls.com>
Subject Subroutine issues
Date Tue, 02 May 2006 17:48:33 GMT
Hello,

I am having some issues with Embperl 2.2.0 and subroutines.

I used to be able to call a subroutine from another file like this in
Embperl 1.3.6:
[- Execute ({ inputfile => 'displayedit.html', import => 1 }) -]
[- EditReport -]

displayedit.html
[$ sub EditReport $]

     (code & html)

[$ endsub $]



Under 2.2.0, I get a blank page.  Once in a great while it will actually
work.

If I do this to the displayedit.html file:

<BR>
Loaded file
<BR>
[$ sub EditReport $]

     (code)

[$ endsub $]

I will see the line "Loaded file", but nothing from the subroutine.

Any ideas?

Keven Murphy
murphyk@gdls.com

Murphy's Law
((U+C+I)x(10-S))/20xAx1/(1-sin(F/10))
U = Urgency    C = Complexity
I = Importance S = Skill
F = Frequency  A = Aggravation



This is an e-mail from General Dynamics Land Systems. It is for the intended recipient only
and may contain confidential and privileged information.  No one else may read, print, store,
copy, forward or act in reliance on it or its attachments.  If you are not the intended recipient,
please return this message to the sender and delete the message and any attachments from your
computer. Your cooperation is appreciated.

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message