perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "HALL, SUSAN \(SBCSI\)" <sh9...@att.com>
Subject RE: AIX/IHS and embperl build issues
Date Mon, 15 May 2006 14:18:43 GMT

Gerald,

I have given up for the time being at least on the attempt to configure
aix52, ibm httpserver apache2, modperl2 and embperl2. We got the empperl
DSO installed finally, but the modperl just core dumps when I send a
request to the webserver.  We've decided to attempt the hopefully easier
job of building this on the apache1 version of the ibm httpserver.

The IBM httpserver apache1 version  is 1.3.28.1.  I made and installed
modperl 1.0 without any apparent issue.  I am trying to make
HTML::Embperl 1.3.26 and get the following errors.  I am using perl
5.6.1 for this, since it's closest to the installation that I have to
migrate to this new platform.

cp Embperl.pod blib/lib/HTML/Embperl.pod
cp Faq.pod blib/lib/HTML/Embperl/Faq.pod
cp Changes.pod blib/lib/HTML/Embperl/Changes.pod
cp FeaturesD.pod blib/lib/HTML/Embperl/FeaturesD.pod
cp Embperl.pm blib/lib/HTML/Embperl.pm
...
...
cp IntroEmbperlObject.pod blib/lib/HTML/Embperl/IntroEmbperlObject.pod
        /appl/as/mps/perl-5.6.1/bin/perl
"-I/appl/as/mps/perl-5.6.1/lib/5.6.1/aix"
"-I/appl/as/mps/perl-5.6.1/lib/5.6.1" -e 'use ExtUtils::Mksymlists;
Mksymlists("NAME" => "HTML::Embperl", "DL_FUNCS" => {  }, "FUNCLIST" =>
[], "DL_VARS" => []);'
        /appl/as/mps/perl-5.6.1/bin/perl
-I/appl/as/mps/perl-5.6.1/lib/5.6.1/aix
-I/appl/as/mps/perl-5.6.1/lib/5.6.1
/appl/as/mps/perl-5.6.1/lib/5.6.1/ExtUtils/xsubpp  -typemap
/appl/as/mps/perl-5.6.1/lib/5.6.1/ExtUtils/typemap -typemap typemap
Embperl.xs > Embperl.xsc && mv Embperl.xsc Embperl.c
        cc -c -I/usr/HTTPServer1/include -I/usr/HTTPServer1/regex
-I/usr/HTTPServer1/os/unix
-I/appl/as/src/Embperl/HTML_Embperl/HTML-Embperl-1.3.6/xs -D_ALL_SOURCE
-D_ANSI_C_SOURCE -D_POSIX_SOURCE -qmaxmem=16384 -q32 -D_LARGE_FILES
-qlonglong -O    -DVERSION=\"1.3.6\"  -DXS_VERSION=\"1.3.6\"
-I/appl/as/mps/perl-5.6.1/lib/5.6.1/aix/CORE -DAPACHE  -o Embperl.o
Embperl.c
"Embperl.c", line 275.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
"Embperl.c", line 299.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
"Embperl.c", line 320.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
"Embperl.c", line 343.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
"Embperl.c", line 395.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
"Embperl.c", line 414.1: 1506-277 (S) Syntax error: possible missing ';'
or ','?
etc.
etc.

-----Original Message-----
From: Gerald Richter [mailto:richter@ecos.de] 
Sent: Thursday, May 04, 2006 3:57 AM
To: MARK, STU (SBCSI)
Cc: embperl@perl.apache.org
Subject: RE: AIX/IHS and embperl build issues 


> 
> 	well, in case anybody else asks you.. We got it to load.

Great!

> 	We added -bexpall to the link line for the shared object.
> 	Apparently the embperl_module isn't exported by default.
> 	Exporting everything makes it work.

ok

> 	Or at least load. We're still having trouble, but at
> least it loads now.
> 

Ok, let me know how it goes on.

Gerald

P.S. Please CC the embperl list, so other can participate



> 
> -----Original Message-----
> From: Gerald Richter [mailto:richter@ecos.de]
> Sent: Wednesday, May 03, 2006 5:23 AM
> To: MARK, STU (SBCSI); embperl@perl.apache.org
> Cc: HALL, SUSAN (SBCSI)
> Subject: RE: AIX/IHS and embperl build issues 
> 
> 
> > 
> > I'm trying to help sue get embperl working on aix 5.2 In 
> > reading the README.v2 you mention a lot of structural changes.
> > I'm not the perl guy, I'm the c/c++ AIX guy trying to help 
> > out and it occurs to me that if the whole thing was rewritten 
> > for apache 2/HIS can we expect the embedded perl application 
> > we are trying to migrate to work unchanged?
> > 
> 
> Most of it will work unchanged, but there a few little tweaks 
> you might
> have
> to do, depending on how the application is written.
> 
> > If not, this might be a wasted effort, because we don't have 
> > anybody to port this application, and might be better off 
> > writing the application another way. Probably not though, it 
> > is a big application and a small timeframe and we need to get 
> > something working.
> 
> The changes you might have to do, are small, so also somebody with
> little
> knowlegde of Perl should be able to do so.
> 
> In case this is an option for you, we can also make these changes for
> you as
> consulting work.
> 
> > 
> > My next question is what is the purpose of src.pm. Apparently 
> > part of mod_perl 1.x and not 2.x This is the first error I 
> > encounter so this is the one I'm trying to fix.
> > What is this pm for and can I live without it or has its 
> > workings been implemented somewhere else?
> > 
> 
> Apache::src gives informations about the build flags from 
> mod_perl 1. In
> mod_perl these informations are taken from Apache2::BuildConfig. An
> object
> of Apache2::BuildConfig should normaly exist in $mp2cfg, so 
> Apache::src
> is
> not used for mod_perl 2.
> 
> Both modules are used to determinate the ldflags and other 
> build flags.
> 
> Note: Embperl 1.3.x does not work with Apache 2 at all, you 
> need to use
> Embperl 2
> 
> Gerald
> 
> 
> 
>  
> ** Virus checked by BB-5000 Mailfilter ** 
> 
> 
>  
> ** Virus checked by BB-5000 Mailfilter ** 
> !DSPAM:4458f61189432084124948!
> 


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message