perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Sapovits <steve...@comcast.net>
Subject Embperl::Object environment variables
Date Fri, 28 Apr 2006 09:19:49 GMT

Now that I can build (thanks Gerald) I'm trying to set up an
object oriented page hierarchy.  I get the basics to work.
However, the environment settings in my Apache <VirtualHost>
section don't appear to be having any effect.  For example,
I set logging levels and get nothing and I have to use the
default object base '_base.epl' instead of the sample I set
up 'base.epl' (and I've tried other names).  I changed other
settings in the <VirtualHost> to verity it's getting used as
a whole.  Those changes did take effect.  That leads me to
believe I need some other Embperl setting.  My <VirtualHost>
section looks like this:

NameVirtualHost *:80

<VirtualHost *:80>
     ServerName       secdevfdsapp01.gspt.net
     ServerAdmin      sapovitss@xxxxxx.com
     DocumentRoot     /feeds/htdocs
     DirectoryIndex   index.html
     ErrorLog         logs/error_log
     TransferLog      logs/access_log
     PerlSetEnv       EMBPERL_ESCMODE 0
     PerlSetEnv       EMBPERL_OPTIONS 16
     PerlSetEnv       EMBPERL_MAILHOST localhost
     PerlSetEnv       EMBPERL_OBJECT_BASE base.epl
     PerlSetEnv       EMBPERL_OBJECT_FALLBACK notfound.html
     PerlSetEnv       EMBPERL_DEBUG 10477
     PerlSetEnv       EMBPERL_VIRTLOG 10477
</VirtualHost>

I've changed things like DocumentRoot to test the overall
use of the section.

Any ideas appreciated.  As noted before, this is Apache 2.2.0,
Embperl 2.2.0, mod_perl 2.0.2.

-- 
Steve Sapovits  steves06@comcast.net

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message