perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Sapovits <steve...@comcast.net>
Subject Re: Linux/Apache2 build errors
Date Thu, 27 Apr 2006 04:57:30 GMT

Gerald Richter wrote:

> These two seems to be ok, but it looks like that the CCFLAGS are not 
> passed
> to the sub Makefiles.

> So the quick fix should be to search the line CCFLAGS = in the 
> Makefile and
> put this line in all Makefiles in the subdirectories.

> Let me know if it works. If yes, I will automate this

I replied:

> Thanks Gerald.  You mean in all Makefiles in the Embperl subdirectories
> only, correct?  I should be able to try this now ...

This worked.  Many thanks.

Now that it builds, 'make test' shows one failure, but I'm not
sure if this will matter or not.  I'll post any other issues as
they arise.  Here's the 'make test' failure (after may 'ok' results):

#194 EmbperlObject/epoincdiv.htm...
Error in Line 286
Is:     ><P>2.2.0<P><
Should: ><P>2.1<
Input:          test/html/EmbperlObject/epoincdiv.htm
Output:         test/tmp/out.htm
Compared to:    test/cmp/epoincdiv.htm
Log:            test/tmp/test.log
Testparameter:
   cgi = 0
   offline = 0

  ERRORS detected! NOT all tests have been passed successfully

make: *** [test_dynamic] Terminated
Terminated

-- 
Steve Sapovits  steves06@comcast.net

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message