perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stepanov <stepa...@francoudi.com>
Subject Re: Embper 2.10 and Apache 2.2.0
Date Mon, 10 Apr 2006 12:59:42 GMT
Gerald Richter wrote:
>> I tried the latest version of Embperl but without any luck. I 
>> still have a Segmentation fault. Here is a backtrace:
>>
>>     
>
> Does make test work for you, or does the segfault also occur during make
> test?
>   
Not. Test doesn't give the segfault . It crash with error:

#0 ascii...                   ERR:Server closed connection without 
sending any data back
> What do you do to produce the segfault?
>   
Any request to any Embperl web applications. For example this simple page:
[-
    our $test = 'This is just a test ...';
-]

TEST: [+$test+]
> Does it occur during startup or restart?
>   
It occur during q request.
> Does it only occur when you request a special page or for every page?
>   
For every Embperl pages. PHP and Mason works fine.

P.S. I have following Embperl configuration in /etc/httpd/conf.d/perl.conf:

LoadModule embperl_module 
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/Embperl/Embperl.so

AddType text/html .epl

PerlModule Embperl

<FilesMatch ".*\.epl|.*\.htm?$">
        SetHandler perl-script
    PerlHandler Embperl
    Options ExecCGI
</FilesMatch>

> Gerald
>
>
>
>  
> ** Virus checked by BB-5000 Mailfilter ** 
>
>   


-- 
Best regards, 
Michael Stepanov
Senior Software Developer
PrimeTel Ltd
Tel: +357 25-867154
Email: stepanov@francoudi.com


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message