perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: AIX/IHS and embperl build issues
Date Fri, 21 Apr 2006 12:19:05 GMT
Hi,

> 
> Line 53 is my LoadModule statement:
> LoadModule  embperl_module
> /usr/opt/perl5/lib/site_perl/5.8.0/aix-thread-multi/auto/Embpe
> rl/Embperl
> .so
> 

This is ok

> 
> Running nm on Embperl.so shows:
> 
> => nm ./Embperl.so | grep embperl_module
> embperl_module       D       83448          56
> embperl_module       d      114844           4
> 
> 
> Another piece of info on this:  I have the AIX compiler on 
> one machine only, so I made all there and tarred up and 
> copied over all the modperl and embperl files.  The system I 
> compiled on is a match as far as the AIX, IHS and perl 
> versions, and the IHS and perl directory paths go.
> 

It should be no problem that your compiler is on a different machine.

I never have used AIX, I only know that the compiler/linker works different
than on other Unix systems.

I think there is some export file which contains the symbols nessarry, but I
don't know exactly.

We would need somebody who has more knowledge of the build process on AIX

Gerald


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message