perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Embperl 2.1.0, mod_perl 2.0.2, Apache 2.2
Date Fri, 10 Mar 2006 20:34:40 GMT
> 
>     I applied Andargor's patches to EmbPerl 2.1.0 and it 
> build fine, seems to run okay too. 


I didn't had the time to put together a new version which includes this
patch, but it's the right way to go and I will hopefully release a new
Embperl version.

> That leads me to another 
> question.  When I build EmbPerl I do so against httpd-2.0.55 
> first, then copy the EmbPerl.so file into 
> httpd-2.0.55/modules/ .  I do the same thing for httpd-2.2.0 
> (build, selecting the apache source path as that for 
> httpd-2.2.0, copy the Embperl.so file etc).  Am I shooting 
> myself in the foot here? I assume there's stuff specific to 
> each apache version in the different .so files, is that right?
> 

That sounds right. Apache 2.0 and 2.2 are NOT binary compatible, so you have
to recompile for every version, as you do.

Gerald


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message