perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Win32 Embperl fails to run with libxml2.dll error
Date Tue, 24 Jan 2006 04:24:10 GMT
> 
> Wondering if Win32 build is working.  Followed the directions 
> on th Embperl website and no luck.
>  
> Apache refused to start, popping up an error at the 
> "PerlModule Embperl" directive, so I ran embpexec.bat, which 
> popped up the same error in a windows dialog box.
>  
> The error is:
>    The procedure entry point xmlLoadExtDtdDefaultValue could 
> not be located in the dynamic link library
>    libxml2.dll.
>  

Looks like a version mismatch, that Embperl is compiled for a different
version of libxml2

Did you have the old libxml2 and libxslt dlls from you 5.6 install? Could
you try these?

If not I can send you mine per private email

Gerald




> When running the bat file, I also get the expected error from 
> Dynaloader:
>  
>     Can't load 
> 'C:/devtools/perl/site/lib/auto/Embperl/Embperl.NoApache.dll' 
> for module Embperl: load_file:The
>     specified procedure could not be found at 
> C:/devtools/perl/lib/DynaLoader.pm line 230.
>     at C:\devtools\perl\bin\embpexec.bat line 37 
>     Compilation failed in require at 
> C:\devtools\perl\bin\embpexec.bat line 37.
>     BEGIN failed--compilation aborted at 
> C:\devtools\perl\bin\embpexec.bat line 37.
>  
> Versions of the bits:
>     ActiveState Perl: 5.8.7 
>     Mod_perl 1 (what ever version comes with mod_perl-1.ppd)
>     Embperl-1.ppd was used
>     Apache/1.3.34 (Win32) 
>  
> My libxml2.dll came from theoryx5 (twice, first by Embperl 
> install and second time a manual download), but I also tried 
> a win32 build from the libxml project.  Exact same error.
>  
> Yes, libxml2.dll is found in the path, other you would get an 
> error that it could not be found.
>  
> I did notice someone else posted this problem to the list, 
> but I did not see any follow up solutions.
>  
> I have Embperl running on Win32 under AS perl 5.6 from an 
> install I did long ago, but I have to be on 5.8.x for this project.
>  
> Any help would be greatly appreciated!  
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
> 
> 
>  
> ** Virus checked by BB-5000 Mailfilter ** 
> !DSPAM:43d54b02174541372564696!
> 


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message