perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Cookies not working at all!!
Date Wed, 04 Jan 2006 20:10:32 GMT
Hi,

Please add a

PerlModule Embperl

To your httpd.conf (in addition and after the LoadModule embperl_module...)

Also please remove the PerlSetEnv bevore the Embperl configuration
directives, since it is no longer needed for Embperl 2 and will not work
correctly, unless you add an EmbperlUseEnv on

If it still doesn't work, please enable the dbgSession flag and send the
embperl.log file

Gerald


---------------------------------------------------------------------------
Gerald Richter            ecos electronic communication services gmbh
IT-Securitylösungen * Webapplikationen mit Apache/Perl/mod_perl/Embperl

Post:       Tulpenstrasse 5          D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de          Voice:   +49 6133 939-122
WWW:        http://www.ecos.de/      Fax:     +49 6133 939-333
---------------------------------------------------------------------------
ECOS BB-5000 Firewall- und IT-Security Appliance: www.bb-5000.info
---------------------------------------------------------------------------

  

> -----Original Message-----
> From: Tony [mailto:prtvy@yahoo.com] 
> Sent: Friday, December 30, 2005 7:14 AM
> To: embperl@perl.apache.org
> Subject: Cookies not working at all!!
> 
>   I guess I am missing something of the basics here, and this 
> is why I am asking for help. Here is my simple test case:
> 
> ---> file1.html <---
> <HTML>
> [-
>   $udat{foo} = 'bar' ;
> -]
> Click <a href="file2.html">here</a> to load next page.
> </HTML>
> ----> file2.html <---
> <HTML>
> foo = [+$udat{foo}+]
> </HTML>
> ---> base.epl <---
> [- Execute('*') -]
> 
>   Observed behaviour: After first page is fully loaded I can 
> see a cookie was sent and recorded by the WEB client (Firefox 
> in my case). Still when the second page is loaded the user 
> value stored in %udat hash is no longer present...
> Moreover: the cookie is no longer on the browser side.
>   On the side I observed a single row being added into the 
> SESSIONS table after the first page was loaded. This row reads:
> 
> select * from sessions ;
>                 id                | a_session 
> ----------------------------------+-----------
>  fb4a15184ff5e10560cf23c33eaa1d76 |
> (1 row)
> 
>    (BTW: this line persists even after the cookie has 
> dissapeared from the browser side).
> 
>    For the curios eye I am including a full log of the 
> messages exchanged by the WEB client with Apache server.
>     I am also attaching the "httpd.conf" file in the hope 
> somebody can help me.
> 
>    Neddless to say I am quite desperate on this I WOULD 
> KINDLY APPRECIATE ANY CONSTRUCTIVE HELP FROM ANYBODY ON THIS MATTER.
> 
> --Anton (Tony) Ghiugan
> 
> 
> 
> 	
> 		
> __________________________________
> Yahoo! for Good - Make a difference this year. 
> http://brand.yahoo.com/cybergivingweek2005/
> 
>  
> ** Virus checked by BB-5000 Mailfilter ** 
> !DSPAM:43b4d06144793509513887!
> 


 
** Virus checked by BB-5000 Mailfilter ** 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message