perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wilde, Donald" <dwi...@sandia.gov>
Subject RE: Embperl 2.1 - memory wrap on BSD (was: won't make -- missing typemap)
Date Thu, 15 Dec 2005 14:06:50 GMT
No, I can't trap it. When I run testgdb, the debugger does not
immediately start. I have to type 'run'. When I do so, it appears to die
immediately.

The line in Embperl.pm that is causing the crash is 

Init ($srv_rec, \%initparam) ;

Do you want me to instrument that call to see what is blowing up?


--
Don Wilde    Org 01737    505-844-1126
A man who carries a cat by the tail learns something he can learn in no
other way. - Mark Twain 



-----Original Message-----
From: Gerald Richter [mailto:richter@ecos.de] 
Sent: Thursday, December 15, 2005 3:31 AM
To: Wilde, Donald
Cc: embperl@perl.apache.org
Subject: RE: Embperl 2.1 - memory wrap on BSD (was: won't make --
missing typemap)

Hi, Gerald -
> 
> output of make testgdb:
> 
> (gdb) run
...
> (gdb) bt
> No stack.
> 

Ok, that's not so much.

> What should I do differently?

How long does it take from "loading..." until the error apears?

Is it long enough to hit Ctrl-C?

If yes, do so and type bt again. If you get a stackbacktrace this time,
it would be helpfull if you run

 perl Makefile.PL debug
 make

Gerald

P.S. Please keep the discussion on the list, so other people who might
have similar problems can find it in the archives


 
** Virus checked by BB-5000 Mailfilter ** 




---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message