perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gavin Carr <ga...@openfusion.com.au>
Subject Re: make test failure
Date Tue, 04 Oct 2005 02:13:02 GMT
On Mon, Oct 03, 2005 at 01:46:09PM +0200, Gerald Richter wrote:
> > On Mon, Oct 03, 2005 at 07:28:05AM +0200, Gerald Richter wrote:
> > > > Yep, I've got 3.10, as shipped with RHEL4.
> > > > 
> > > > So this looks like a bug in the test then? 
> > > 
> > > Not sure. It works for me with very similar versions.
> > > 
> > > Could you please run
> > > 
> > >   make test TESTARGS="-h 76"
> > > 
> > > And send me the resulting test/tmp/test.log
> > 
> > Attached.
> 
> This really looks like a CGI.pm issue. Perl 5.8.5 comes with CGI.pm 3.05.
> Are you really sure you are using 3.10?
> 
> Embperl's Makefile.PL will show you the version it uses.

Bah, you're quite right Gerald - it is CGI 3.05 - I must have checked the wrong
box. 

Is this requirement documented anywhere? I just rebuilt mod_perl using 
mod_perl 2.0.1 and there don't appear to be either any warnings or a documented 
requirement for a newer CGI.  

Would it be worth adding a test to Embperl somewhere to check and flag this 
issue, as it's not at all obvious from the test failure.

Thanks again for your help.

Cheers,
Gavin



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message