perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From l...@chipcity.com.au
Subject probs compile Embperl-2.0rc5
Date Sun, 25 Sep 2005 06:45:42 GMT
Hi.

I've been trying to get Embperl to work.
I've compiled apache, mod_perl successfully.
Then when I compile Embperl, I get an error when it's doing the tests.

I've read the FAQ:
/~~~~~~~~~~~~~~~~~~
Running ’make test’ fails with an error message at loading of Embperl
       (even though mod_perl compiled and tested cleanly!)

\_________________
And when I do this:
/~~~~~~~~~~~~~~~~~~
Try:

       1.) make clean
       2.) perl Makefile.PL
           NOTE: answer _no_ to mod_perl support. (This is important!)

       3.) make test
\___________________

All tests are successful.

============================================================
So I did this:
/~~~~~~~~~~~~~
Try rebuilding Apache and mod_perl from scratch, and make sure you do
       not strip symbols out of either.
\____________

However I didn't get a successful result.
Any help would be appreciated.

I have apache2054, mod_perl-2.0.1, Embperl-2.0rc5

Since the Embperl 'make test' was the only step that partially failed, I went
ahead and did 'make install' anyway.
Then I tried the following example:

httpd.conf
/~~~~~~~~~~~~~~~~~~~~~~~~~~~
        NameVirtualHost 10.1.1.3:80
		
        <VirtualHost 10.1.1.3:80>
                ServerName www.mydomain.com
                ServerAdmin webmaster@mydomain.com
                DocumentRoot /www/mydomain/com/htdocs
                DirectoryIndex index.html
                ErrorLog /www/mydomain/com/logs/error_log
                TransferLog /www/mydomain/com/logs/access_log
                PerlSetEnv EMBPERL_ESCMODE 0
                PerlSetEnv EMBPERL_OPTIONS 16
                PerlSetEnv EMBPERL_MAILHOST mail.mydomain.com
                PerlSetEnv EMBPERL_OBJECT_BASE base.epl
                PerlSetEnv EMBPERL_OBJECT_FALLBACK notfound.html
                PerlSetEnv EMBPERL_DEBUG 0
        </VirtualHost>
		
        # Set EmbPerl handler for main directory
        <Directory "/www/mydomain/com/htdocs/">
                <FilesMatch ".*\.html$">
                        SetHandler  perl-script
                        PerlHandler HTML::EmbperlObject
                        Options     ExecCGI
                </FilesMatch>
                <FilesMatch ".*\.epl$">
                        Order allow,deny
                        Deny From all
                </FilesMatch>
        </Directory>
\______________________________

And the following code:

/~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/base.epl

        <HTML>
        <HEAD>
                <TITLE>Some title</TITLE>
        </HEAD>
        <BODY>
        Joe's Website
        <P>
        [- Execute ('*') -]
        </BODY>
        </HTML>

/hello.html

        Hello world!
\_______________________________
I couldn't get this to work. The browser said "Internal server error" (I chmod
+x the files but no improvement)



Further to that I tried a '.epl' file with the following in my httpd.conf
/~~~~~~~~~~~~~~~~~~~
PerlModule Embperl

AddType text/html .epl

<Files *.epl>
	SetHandler  perl-script
	PerlHandler Embperl
	Options     ExecCGI
</files>
\___________________

I tried this out with a .epl file and it worked. This was a list of vegetables
(can't find the file any more)

Help!

Kind regards.
Luke.


-- 
............._..
.|  .| |.|/.|_ .
.|__.|_|.|\.|_ .
:61 421 276 282:

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message