perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Embperl::Object::Execute segfault
Date Tue, 13 Sep 2005 06:56:20 GMT
Hi,

> 
> The app is my ewok CMS - 
> http://www.openfusion.com.au/labs/ewok/. I use 
> Embperl::Object::Execute for 'publishing' static pages to an 
> output scalar (and thence to a file). In ewok the code lives 
> in a perl module rather than in the page like the example 
> above; the actual app code looks like this:
> 
>     if ($Config->{EMBPERL_VERSION} == 2) {
>         require Embperl::Object;
>         my $execute = {
>             appname => 'ewok',
>             inputfile => "$fs_dir/$f",
>             output => \$new,
>             fdat => $fdat,
>             object_base => $base,
>             object_stopdir => $src_fs_dir,
>             object_addpath => [ split /[;:]/, $addpath ],
>             syntax => 'EmbperlBlocks',
>         };
>         Embperl::Object::Execute($execute);
>     }
> 
> Does that make sense Gerald? The corresponding code works 
> fine using HTML::EmbperlObject::Execute.
> 

Yes, this makes more sense.

Do you call this from the commandline or from within mod_perl?

If you do it from within mod_perl, can you try it from the command line?

Gerald


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message