perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Embperl::Object::Execute segfault
Date Tue, 13 Sep 2005 03:21:58 GMT
Hi,

> 
> 
> Porting an apache1 / HTML::Embperl app to apache2 / Embperl, 
> and I'm getting segfaults doing an Embperl::Object::Execute 
> under mod_perl. Simple example:
> 
> - simple.html:
> 
> 2 + 2 = [+ 2 + 2 +]
> 
> - execute.html:
> 
> [- Embperl::Object::Execute({ inputfile => 'simple.html', 
> appname => 'test' }) -]
> 

Looks like your are calling Embperl::Object from within an Embperl page,
which doesn't make sense to me (also it should not segfault). What do you
want to do?

Gerald



> This segfaults. Straight Embperl::Execute works fine. My app 
> version has all the additional Embperl::Object object_base, 
> object_stopdir, object_addpath parameters as well, but it 
> doesn't make any difference.
> 
> Versions are httpd 2.0.52, mod_perl 2.0.0, Embperl 2.0.0. 
> 
> Anyone else seen this or can replicate it?
> 
> Cheers,
> Gavin
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message