perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Tetreault <Brian.Tetrea...@Sun.COM>
Subject using embperl, apache 2.0, activePerl 5.8
Date Sun, 15 May 2005 19:46:06 GMT
is this possible? i'm running WinXP, have apache 2.0 successfully
installed, and want to start playing around with embperl. so, i followed
the instructions on:

http://perl.apache.org/embperl/pod/INSTALL.htm#sect_7

installing mod_perl worked just fine, and apache starts fine when I add
the following to httpd.conf:

LoadFile "D:/Perl/bin/perl58.dll"
LoadModule perl_module modules/mod_perl.so

then, i installed Embperl using:

ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl-1.ppd

that seemed to work just fine. however, for some reason i can not run
perl and load the Embperl module. adding this to httpd.conf:

PerlModule Embperl

results in:

[error] Can't load Perl module Embperl for server...

i tried creating a simple Perl script to run from a command prompt that
included "use Embperl;" and when I do a windows error box pops up with:

"The procedure entry point xmlLoadExtDtdDefaultValue could not be
located in the dll libxml2.dll."

Does anyone know what this means? Could this be what is causing apache
to not load the module? Thanks so much in advance.

-Brian

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message