perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Problem with http-Headers
Date Mon, 11 Apr 2005 04:02:24 GMT
Hi,

> 
> I updated to the newest Debian-Packages from sid and have now 
> the following Problem. Sorry, i dont know if it is an embperl 
> or apache or modperl-Problem.
> 
> The http-Headers are not in front of the file, so the browser 
> assumes it is a text-file and display something like this:
> 

It looks like that you are using print inside your Embperl pages. If you use
print, you should replace it with 

print OUT "xxx" ;

Gerald



> ------------------schnipp-----------------------schnipp-----
> 
> The city (2, 0) is occupied by the Mathemagier (<a 
> href="command.epl?cmd=CH_STATUS&other=14">allied</a>, <a 
> href="command.epl?cmd=SEND_MSG&other=14">contact</a>).
> It's the home town of them.<p>
> Here is 1 warrior of the Mathemagier (<a 
> href="command.epl?cmd=BLESS_PRIEST&mob=65">bless priest</a>).
> <p>
> <p><a href="command.epl?cmd=PLAGUE&loc=2_0">init plague</a> 
> <p><a href="command.epl?cmd=CH_LUCK">change luck</a> 
> <p><strong>Events</strong><p> <strong> In 11 hours, 38

> minutes and 3 seconds:</strong> A warrior finish his 
> training.<p>HTTP/1.1 200 OK
> Date: Fri, 08 Apr 2005 09:15:19 GMT
> Server: Embperl/2.0rc2 Apache/2.0.53 (Debian GNU/Linux) PHP/4.3.10-10
> mod_perl/1.999.21 Perl/v5.8.4
> Content-Length: 106
> Keep-Alive: timeout=15, max=99
> Connection: Keep-Alive
> Content-Type: text/html; charset=ISO-8859-1
> 
> <html>
> <head><link rel="stylesheet" type="text/css" 
> href="aymargeddon.css"> </head> <body> </body></html> The

> city (3, 0) is occupied by the Mathemagier (<a 
> href="command.epl?cmd=CH_STATUS&other=14">allied</a>, <a 
> href="command.epl?cmd=SEND_MSG&other=14">contact</a>).
> <p>
> Here is 1 warrior of the Mathemagier (<a 
> href="command.epl?cmd=BLESS_PRIEST&mob=26">bless priest</a>).
> <p>
> 
> ------------------schnipp-----------------------schnipp-----
> 
> The part before the headers seems to be from another call to 
> the same script as the part after the headers. in some other 
> cases the browser displays nothing, but i think it could be 
> the same problem.
> 
> Thanks for any hint.
> 
> Benni
> --
> http://www.aymargeddon.de
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message