perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From allen haim <al...@netherrealm.net>
Subject %udat is empty until I press reload
Date Tue, 15 Feb 2005 03:28:31 GMT
Hello,

I am having a problem with %udat and would appreciate any help you could
offer.

I have a frameset. The frameset document is called results-frameset.html,
and contains several frames, one of which is results-nav.html.

In results-frameset.html, I have

[-

$udat{'a'} = 'a';
$udat{'b'} = 'b';
$udat{'c'} = 'c';

etc.

-]

<frameset ... >
   <frame src='results-nav.html'... >
   <frame ... >
   <frame ... >
   etc.
</frameset>

and then in results-nav.html I try to read %udat:

my $a = $udat{'a'};
etc.,

What happens is: I restart the web server, then bring up the pages. %udat is
empty and my application crashes. 

Then, I press 'reload' -- suddenly everything works perfectly. 

Why is %udat doomed to be empty on the first hit to the server?

Here is the section from httpd.conf:

PerlSetEnv EMBPERL_SESSION_HANDLER_CLASS "Embperl::Session"
#PerlSetEnv EMBPERL_SESSION_CLASSES "File Null"
#PerlSetEnv EMBPERL_SESSION_ARGS "Directory=/tmp"

I've tried it with the last two lines uncommented, too.

I am using Apache::Session. Embperl-2.0rc2, ModPerl-2.0, and Apache/2.0.52.

One more thing: if I run the server with apachectl -X, it works fine on the
first hit -- but extremely slowly.

I also tried such things as 

my $udat = Embperl::Req::SetupSession($req);

and

$req->SetSessionCookie;

but it says they are not implemented.

Thanks for any help,

Allen Haim

-- 
happy random george orwell advice for making tea:

	The milk-first school can bring forward some fairly strong arguments, but I maintain that
my own argument is unanswerable.

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message