perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hartmaier Alexander" <Alexander.Hartma...@t-systems.at>
Subject AW: Debian and libembperl-perl
Date Sat, 08 Jan 2005 11:15:10 GMT
Thanks Gus!
Till now i compiled it for myself...is finished in no time and works flawless.
Ah I just remembered that I need to compile with epchar.min for UTF-8 support so I think the
debian package is no use for me.

-Alex


-----Ursprüngliche Nachricht-----
Von: Angus Lees [mailto:gus@debian.org] 
Gesendet: Samstag, 8. Januar 2005 00:54
An: Pete Moran
Cc: embperl@perl.apache.org
Betreff: Re: Debian and libembperl-perl

At Thu, 6 Jan 2005 12:39:39 +1100, Pete Moran wrote:
> I am trying to get a apache2 server with mod_perl2 and embperl running using
> just packages from apt-get however seem to be running into some problems.
> 
> Am running Debian Sarge with Kernel 2.4.27-1 on a 386 server.
> 
> I firstly installed Apache2, then mod_perl2 then libembperl-perl have made no
> changes to any of the default Debian configurations, I simply created a test
> file test.epl in the document root with
> 
> [- print STDERR ?HELLO? -]
> 
> When running this I get back a internal Server error with the following
> 
> [Thu Jan 06 12:30:05 2005] [error] [594]ERR:  24:  Error in Perl code: Can't
> call method "component" on an undefined value at /usr/lib/perl5/Embperl/App.pm
> line 58.\n
> [etc]

I just installed apache2, libapache2-mod-perl2 and libembperl-perl on
Debian sarge and ran your test.epl with no problems.  You didn't
mention specific package versions in your post, could you give me the
output of "dpkg -l apache2 libapache2-mod-perl2 libembperl-perl"

For reference, I just tested with:
ii  apache2        2.0.52-3       Next generation, scalable, extendable web se
ii  libapache2-mod 1.99.14-4      Integration of perl with the Apache2 web ser
ii  libembperl-per 2.0debian-4    A system for building dynamic websites with 


Alex, there have been libembperl-perl (2.0) packages in Debian
unstable for 2 years now ;)  They only made it into testing (sarge) in
August/2004 though.  There are also the older libhtml-embperl-perl (1.3)
packages which should be able to be installed simultaneously.

-- 
 - Gus


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*
Hinweis: Dieses E-mail kann vertrauliche und geschützte Informationen enthalten.
Sollten Sie nicht der beabsichtigte Empfänger sein, verständigen Sie bitte den Absender
und löschen Sie dieses E-mail dann sofort.

Notice: This e-mail contains information that is confidential and may be privileged.
If you are not the intended recipient, please notify the sender and then delete this e-mail
immediately.
*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*"*

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message