perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: Embperl::Object and FastCGI?
Date Sun, 21 Nov 2004 14:00:52 GMT
Hi,

Could you try to add 

CGI::initialize_globals () ;

End the end of the page that receives the upload.

Does this change anything?

Gerald


---------------------------------------------------------------------------
Gerald Richter            ecos electronic communication services gmbh
IT-Securitylösungen * Webapplikationen mit Apache/Perl/mod_perl/Embperl

Post:       Tulpenstrasse 5          D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de          Voice:   +49 6133 939-122
WWW:        http://www.ecos.de/      Fax:     +49 6133 939-333
---------------------------------------------------------------------------
ECOS BB-5000 Firewall- und IT-Security Appliance: www.bb-5000.info
---------------------------------------------------------------------------
  

> -----Original Message-----
> From: Doug Rayner [mailto:drayner@savicom.net] 
> Sent: Thursday, November 18, 2004 6:54 PM
> To: Gerald Richter; 'Embperl'
> Subject: Re: Embperl::Object and FastCGI?
> 
> > Can you send me your epofastcgi.pl script that you are using for 
> > working with FCGI and Embperl::Object?
> 
> I've attached it.
> 
> Thanks and regards,
> 
> Doug Rayner
> Senior System Architect
> Savicom: Next Generation eMail Marketing http://www.savicom.net
> (415) 617-9006
> 
> ----- Original Message -----
> From: "Gerald Richter" <richter@ecos.de>
> To: "'Doug Rayner'" <drayner@savicom.net>; "'Embperl'"
> <embperl@perl.apache.org>
> Sent: Wednesday, November 17, 2004 8:56 PM
> Subject: RE: Embperl::Object and FastCGI?
> 
> 
> > >
> > > After this fix, we were able to get things mostly working
> > > with fastcgi.
> > > However, we have encountered a problem with forms which use
> > > encoding type 'multipart/form-data'.  It seems that the form
> > > data read for the first form submitted re-used to all
> > > subsequent form submissions.
> > >
> > > I know that Embperl uses a CGI object to process
> > > multipart/form-data requests.  I know that there was a recent
> > > change to Embperl 2.0 to extend the lifetime of the CGI
> > > object by storing a reference to it in the request object.
> > > However, we do not see this behavior when we use mod_perl, so
> > > it might not be an object lifetime problem.
> > >
> > > We are using CGI v2.81 (and I have also tried with the newer
> > > v3.05), and FASTCGI v0.67.
> > >
> > > Any ideas on what might be happening?
> > >
> >
> > Seems like a problem with FastCGI itself to me. Maybe 
> FCGI.pm keeps the
> > content somewhere and  forgets to release it. I have to dig 
> deeper into it
> > see what's happeing.
> >
> > Can you send me your epofastcgi.pl script that you are 
> using for working
> > with FCGI and Embperl::Object?
> >
> > Gerald
> >
> >
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message