perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Rayner" <dray...@savicom.net>
Subject Embperl::Object and FastCGI?
Date Thu, 04 Nov 2004 22:48:14 GMT
Has any one been successful getting Embperl::Object::  V2.0rc1 configured
and running?

I believe I have apache configured with FastCGI, and have all the dependent
modules installed.  I modified the epocgi.pl script to look like the
embpfastcgi.pl script.  Apache seems to start fast cgi, and it seems to
start epocgi.pl, and it seems to be able to execute some simple requests
(login page), but then I get this error in the apache error log:

[Thu Nov  4 14:42:59 2004] [error] [client 192.168.13.203] FastCGI: server
"/home/drayner/www/fcgi-bin/epocgi.pl" stderr: Thu Nov  4 14:42:59 2004:
Usage: FCGI::Stream::READ(stream, bufsv, len, ...) at
/home/drayner/perllib/lib/perl5/site_perl/5.8.0/sun4-solaris/Embperl/Object.
pm line 145.
[Thu Nov  4 14:42:59 2004] [error] [client 192.168.13.203] FastCGI:
incomplete headers (0 bytes) received from server
"/home/drayner/www/fcgi-bin/epocgi.pl"
[Thu Nov  4 14:42:59 2004] [warn] FastCGI: (dynamic) server
"/home/drayner/www/fcgi-bin/epocgi.pl" (pid 12403) terminated by calling
exit with status '255'
[Thu Nov  4 14:42:59 2004] [warn] FastCGI: (dynamic) server
"/home/drayner/www/fcgi-bin/epocgi.pl" restarted (pid 15767)

Thoughts/recommendations?


Thanks and regards,

Doug Rayner
Senior System Architect
Savicom: Next Generation eMail Marketing
http://www.savicom.net
(415) 617-9006


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message