perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Rayner" <dray...@savicom.net>
Subject Re: Embperl::Object and FastCGI?
Date Wed, 17 Nov 2004 21:03:31 GMT
After this fix, we were able to get things mostly working with fastcgi.
However, we have encountered a problem with forms which use encoding type
'multipart/form-data'.  It seems that the form data read for the first form
submitted re-used to all subsequent form submissions.

I know that Embperl uses a CGI object to process multipart/form-data
requests.  I know that there was a recent change to Embperl 2.0 to extend
the lifetime of the CGI object by storing a reference to it in the request
object.  However, we do not see this behavior when we use mod_perl, so it
might not be an object lifetime problem.

We are using CGI v2.81 (and I have also tried with the newer v3.05), and
FASTCGI v0.67.

Any ideas on what might be happening?

Thanks and regards,

Doug Rayner
Senior System Architect
Savicom: Next Generation eMail Marketing
http://www.savicom.net
(415) 617-9006

----- Original Message ----- 
From: "Doug Rayner" <drayner@savicom.net>
To: "Gerald Richter" <richter@ecos.de>; "'Embperl'"
<embperl@perl.apache.org>
Sent: Sunday, November 07, 2004 7:45 PM
Subject: Re: Embperl::Object and FastCGI?


> Gerald;
>
> Thanks for the quick response.  That fixed the problem!!
>
> Regards,
>
> - Doug Rayner
>
> ----- Original Message ----- 
> From: "Gerald Richter" <richter@ecos.de>
> To: "'Doug Rayner'" <drayner@savicom.net>; "'Embperl'"
> <embperl@perl.apache.org>
> Sent: Saturday, November 06, 2004 5:45 AM
> Subject: RE: Embperl::Object and FastCGI?
>
>
> >>
> >> [Thu Nov  4 14:42:59 2004] [error] [client 192.168.13.203]
> >> FastCGI: server "/home/drayner/www/fcgi-bin/epocgi.pl"
> >> stderr: Thu Nov  4 14:42:59 2004:
> >> Usage: FCGI::Stream::READ(stream, bufsv, len, ...) at
> >
> > Could you please try to add in epio.c after line 487:
> >
> > XPUSHs(sv_2mortal(pBufSV = NEWSV(0, 0)));
> >
> > The following line
> >
> > XPUSHs(sv_2mortal(newSViv (size)));
> >
> > Please let me know if this solves your problem.
> >
> > Gerald
> >
> >
>


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message