perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: httpd stalling.
Date Sun, 19 Sep 2004 12:22:42 GMT
> 
> I added the 2.x about a year later. When I was running the 
> 1.3 alone I also had this problem so I do not think it has 
> something to do with running 2 embperls.
> 

Both 1.3 and 2.0 use the same session handling, so it makes no difference.

> Could it be that the 1.3 causes the trouble?
> If I would make another session table and let the 2.x version 
> use that one could that prevent both of them locking but just 
> the one behaving badly?


I don't think this will help. The problem is not the session table, but the
locking.

Increasing the number of seamphores used (nsem in Apache::Session), will
make this problem to occur more seldom I guess, but will not solve it.

Maybe it helps to switch to the MySQL lock meachnisem, instead of using
semaphores, because it works a little different when aquiring locks

Let me know if this helps

Gerald

> 
> Regards
> 
> Hans de Groot
> 
> 
> 
> Quoting Gerald Richter <richter@ecos.de>:
> 
> > >
> > > And yes I make heavy use of %udat. I am not (yet) using %mdat.
> > >
> > > It would make sensense if had something to do with the sessions.
> > > Any idea how to fix it?
> > >
> >
> > How is your session setup in httpd.conf?
> >
> > And your Apache/SessionX/Config.pm from the site_perl directory?
> >
> > Gerald
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message