perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject RE: another segfault with Embperl2/Apache/static mod_perl
Date Wed, 25 Aug 2004 19:27:26 GMT
Hi,
> 
> I'm willing to run Embperl2 with the stock apache-perl 
> package (Apache with mod_perl module statically linked). So, 
> I downloaded the last Debian libembperl-perl source package 
> and rebuilt it.  (off course, with 
> EPHTTPD=/usr/sbin/apache-perl & apxs-perl).
> 
> Building went fine but "apache-perl -X -f 
> $(dir)/test/conf/httpd.conf" 
> segfault during the make test.
> 

I just tried apache 1.3.31, mod_perl 1.29 and Embperl 2.0rc1 (which is the
same as the current CVS) and don't get any problems durig make test
(everything build from the source).

Are you sure the you build with the same Perl as mod_perl was build,
especialy with the same compiler options. Angus mentioned something that
LARGE_FILE support was compiled in recently. If these settings are different
between Apache/mod_perl and Embperl compiler, there will be a segfault in
any case.

If you made sure that these compiler settings are the same for all builds
and versions of Perl and Apache are the same for mod_perl and Embperl build,
then the question is where does it segfault? Does it perform some test or
does it directly segfault?

If it first performs some test, please send me the test/tmp/test.log and in
any case run

make test TESTARGS="-h --cfgdebug"

And send me the output on the screen and the test/tmp/httpd.err.log

Hopefully together with stackbacktrace this helps to track down the problem.

Gerald

P.S. I will not be able to read mail before Saturday evening or Sunday.
Sorry...


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message