perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Jagdmann <...@cubic.org>
Subject embperl 1.3.6 and apache 1.3.31 problem
Date Sun, 27 Jun 2004 11:33:59 GMT
Hello Developers,

I had a website running for a long time using the following Software: 
perl 5.8.0, embperl 1.3.6, mod_perl 1.27 and apache 1.3.27.
Last week I decided it is time for an upgrade and compiled all of those 
fresh from the sources. Now I have the following: perl 5.8.4, embperl 
1.3.6, mod_perl 1.29 and apache 1.3.31. Apache modules like mod_perl and 
embperl are compiled as DSOs. Both installations used exactly the same 
configuration file.

Now my problem is that the new build does not run. Every time a webpage 
with embperl should be processed the httpd process exists with a 
segmentation fault.

Now I'd like to know how to solve this problem. In the short run I can 
keep running the old installation (which I still have), but I'd like to 
know what are my options.

Are others able to reproduce a SIGSEV with this combination of software? 
Is there an incompatibility between latest version of mod_perl or apache 
with empberl 1.3.6? Is the 1.3.6 version of embperl outdated by now and 
I should convert my codes to the 2.0 version of embperl?

-- 
---> doj / cubic
----> http://cubic.org/~doj
-----> http://llg.cubic.org

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message