perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crawshaw <da...@zentus.com>
Subject Embperl 1.3.6 + FastCGI Form problems
Date Sat, 15 May 2004 23:37:06 GMT
Hi all,

I recently set up Embperl for the first time on a debian-sarge 
(testing) machine. As I want to run setuid scripts, I've opted for 
FastCGI instead of mod_perl. The installation took a while but 
eventually worked, and I have .epl files being processed through 
embpfastcgi.pl. This works really well, until I send a page form data 
via a POST. I get the error:

     FastCGI: server "/var/www/cgi-bin/embperl.pl" stderr:
     Usage: FCGI::Stream::READ(stream, bufsv, len, ...) at
     /usr/lib/perl5/HTML/Embperl.pm line 727.

(I renamed the embpfastcgi.pl script to embperl.pl.)

Versions:
     Perl 5.8.3
     Embperl 1.3.6
     mod_fastcgi 2.2.10
     libfcgi-perl 0.67

There is a tentative reference to this problem in the list archive, but 
no fix. Does anyone have any ideas what might be going on?

To expand on the question, do you still consider Apache + FastCGI + 
Embperl a reasonable setup? Would anyone consider there to be security 
issues with the combination (giving that I'm running setuid scripts)?

Besides the problem above, Embperl runs really well. The advanced 
<table> processing really makes it fun to work with.

Thanks,

-- 
David


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message