perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco Scoffier <ma...@metm.org>
Subject Re: Undefined synbol embperl_module with Debian packages
Date Mon, 26 Apr 2004 20:51:20 GMT
On Sun, Apr 25, 2004 at 01:57:00PM +1000, Angus Lees wrote:
> > Marco Scoffier wrote:
> > >   Syntax error on line 27 of /etc/apache-perl/modules.conf: Can't
> > >   locate API module structure `embperl_module' in file
> > >   /usr/local/lib/perl/5.8.3/auto/Embperl/Embperl.so:
> > >   /usr/sbin/apache-perl: undefined symbol: embperl_module
> > >
> > > I guess it was comiled against the wrong source?  Like kernel modules?
> 
> The debian libembperl-perl package is not compiled with support for
> apache2.  In apache1.3 you don't need the LoadModule line.
> 
Hi Angus thanks for the responce,

The errors referrered to in my message where using the debian
'apache-perl' package which is apache 1.3.29 with mod_perl built in. 
Perhaps you could add a short line or two to the README.debian which
explains that you should use apache + libapache-mod-perl not apache-perl
Or change the dependencies for libembperl-perl.

I have tried the plain 'apache' package + libapache-mod-perl as you
suggested and I am still get weird errors, but I have gotten further.  I
don't know exactly where to send these errors so I'm sending them here.

All the following errors in this email come from these packages:
apache             1.3.29.0.2-5   Versatile, high-performance HTTP
apache-common      1.3.29.0.2-5   Support files for all Apache
apache-utils       1.3.29.0.2-5   Utility programs for webservers
libapache-mod-perl 1.29.0.2-5     Integration of perl with the Apache
libembperl-perl    2.0b10-1       A system for building dynamic websites 
> 
>  LoadModule perl_module /usr/lib/apache/1.3/mod_perl.so
Adding this line to httpd.conf or modules.conf works, and I can run some
simple mod_perl tests I wrote.
>  PerlModule Embperl
This line is the problem.  I add it -> seg-fault both with apachectl
configtest and /etc/init.d/apache start:

 $ apachectl configtest
 Syntax OK
 /usr/sbin/apachectl: line 171: 25891 Segmentation fault      $HTTPD -t

There is nothing interesting in /var/log/apache/error.log 

 [Mon Apr 26 15:58:33 2004] [notice] caught SIGTERM, shutting down

It seems there is something weird with apachectl.  If I start the server
directly, /usr/sbin/apache embperl works! however if I try the
/usr/sbin/apache -t test with the PerlModule Embperl line in httpd.conf
I get a segfault.  As the /usr/sbin/apache -t test is run by apachectl
and /etc/init.d/apache on every server restart, the sysv scripts are
effectively broken.

I double checked my @INC to make sure that I am not pulling in the wrong
Embperl modules:

  for path in  `perl -le 'print  join "\n" , @INC'`; 
  do  find $path -name 'Emb*'; 
  done;

I don't have a startup.pl script to change around the @INC, or any other
directives in httpd.conf which would change it.

Thanks for your help,

-- 
Marco

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message