perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemond, Steve" <SHEM...@SMURFIT.com>
Subject Aix/Apache2/mod_perl2/Perl 5.8.3 tests
Date Thu, 05 Feb 2004 15:46:44 GMT
Hi again friends,

Here is what I get when starting apache2 :

[Wed Feb 04 14:53:51 2004] [notice] Apache/2.0.48 (Unix)
mod_perl/1.99_12 Perl/v5.8.3 configured -- resuming normal operations
[Thu Feb 05 10:39:33 2004] [notice] SIGHUP received.  Attempting to
restart
[Thu Feb 05 10:39:37 2004] [error] Can't load
'/usr/local/lib/perl5/site_perl/5.8.3/aix/auto/Embperl/Embperl.so' for
module Embperl: No such file or directory at
/usr/local/lib/perl5/5.8.3/aix/DynaLoader.pm line 229.
 at (eval 2) line 3
Compilation failed in require at (eval 2) line 3.

[Thu Feb 05 10:39:37 2004] [error] Can't load Perl module Embperl for
server MLATGIS1.smurfit.com:0, exiting...

Here is the result of the find command to know if the 'missing' file is
really there:
$ find / -name Embperl.so -print
/usr/local/lib/perl5/site_perl/5.8.3/aix/auto/Embperl/Embperl.so   <---
the file is there!
/usr/local/cpan/build/Embperl-2.0b10/blib/arch/auto/Embperl/Embperl.so 

Here are lines 229-230 of DynaLoader.pm
my $libref = dl_load_file($file, $module->dl_load_flags) or
 croak("Can't load '$file' for module $module: ".dl_error());

What is wrong there?


Here is what my httpd.conf file looks like :

PerlModule Embperl

Alias /wood/ /prog/www/wood/

<Location /wood/>
  SetHandler  perl-script
  PerlHandler Embperl
  Options     ExecCGI
</Location>


Is this a big problem?

Thanks again for your help,

Regards,

Steve Hemond
Programmeur Analyste / Analyst Programmer
Smurfit-Stone, Ressources Forestieres
La Tuque, P.Q.
Tel.: (819) 676-8100 X2833
shemond@smurfit.com 


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message