perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: Help! Apache problem loading Embperl.so in server startup
Date Sat, 07 Feb 2004 13:56:25 GMT
Mark Bourbonnais wrote:
> If you could please help me, or tell me where and how I can post this
> question to get a response. I searched the archives but found nothing
> similar.
>
> Scenario is as follows:
> I got HTML::Embperl from CPAN ->  perl -MCPAN -e "install
> HTML::Embperl"

You install Embperl 1.3.6 but

>
> Syntax error on line 247 of /etc/apache/httpd.conf:
> Can't locate API module structure `embperl_module' in file
> /usr/local/lib/ perl/5.6.1/auto/Embperl/Embperl.so: apache: undefined
> symbol: embperl_module
>

looks like your httpd.conf is for Embperl 2.0. What is on line 247, if it is
a LOadModule directive, as I guess, then simply remove it. It is not needed
for Embperl 1.3.x

GErald

P.S. Please post any further questions to the Embperl mailing list


--------------------------------------------------------------
Gerald Richter     ecos electronic communication services gmbh
IT-Securitylösungen * dynamische Webapplikationen * Consulting

Post:       Tulpenstrasse 5          D-55276 Dienheim b. Mainz
E-Mail:     richter@ecos.de          Voice:   +49 6133 939-122
WWW:        http://www.ecos.de/      Fax:     +49 6133 939-333
--------------------------------------------------------------
|
|   ECOS BB-5000 Firewall- und IT-Security Appliance: www.bb-5000.info
|
+-------------------------------------------------------------


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message