perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarrod Stenberg <slo...@yahoo.com>
Subject Problems with Embperl 2.0b9 install on RedHat 8
Date Sun, 09 Nov 2003 22:27:11 GMT

I have installed my own compile of Apache 2:
Apache/2.0.48
(./configure -prefix /usr/local/apache2
--enable-rewrite=shared --enable-speling=shared
--enable-usertrack=shared --enable-unique-id=shared
--enable-ssl=shared --enable-so --enable-cgi=shared)

And mod_perl:
mod_perl-1.99_10

Stock RedHat perl:
5.8.0

When I do a make test I get:
Starting httpd...       pid = 1396  ok

Testing mod_perl mode...

#0 ascii...

[-1]Attempt to free unreferenced scalar during global
destruction.
[-2]Attempt to free unreferenced scalar during global
destruction.

Input:   test/html/ascii
Output:  test/tmp/out.htm
Log:     test/tmp/test.log

 ERRORS detected! NOT all test have been passed
successfully


And when I make Embperl with debug and install
regardless of test failure, from gdb:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 1285)]
0x420991c3 in __tz_convert () from /lib/i686/libc.so.6
(gdb) bt
#0  0x420991c3 in __tz_convert () from
/lib/i686/libc.so.6
#1  0x4209808e in gmtime_r () from /lib/i686/libc.so.6
#2  0x40485432 in embperl_CalcExpires (sTime=0x81060f8
"+3M", sResult=0xbfffe8f0 " e\020\b",
    bHTTP=0) at eputil.c:2015
#3  0x404ab389 in
embperl_Apache_Config_AppConfigsCookieExpires
(cmd=0x0, pDirCfg=0x81060f8,
    arg=0x81060f8 "+3M") at epcfg.h:58
#4  0x0807ab7e in invoke_cmd (cmd=0x81060f8,
parms=0xbfffeab0, mconfig=0x80f9340, args=0x80f99bd
"")
    at config.c:713
#5  0x0807b565 in ap_walk_config_sub
(current=0x80f9998, parms=0xbfffeab0,
section_vector=0x80eeb58)
    at config.c:1085
#6  0x0807b5ec in ap_walk_config (current=0x80f9998,
parms=0xbfffeab0, section_vector=0x80eeb58)
    at config.c:1124
#7  0x0807c01b in ap_process_config_tree
(s=0xbfffe834, conftree=0x80f1d28, p=0x80b2910,
ptemp=0x0)
    at config.c:1654
#8  0x0807e2f9 in main (argc=2, argv=0xbfffebb4) at
main.c:581
#9  0x420158f7 in __libc_start_main () from
/lib/i686/libc.so.6

When I take this:
EMBPERL_COOKIE_EXPIRES "+3M"

Out of httpd.conf, httpd will start up without a sig
fault.  However, I don't have cookie support which I
need.

I spent an awful lot of time on this already.  I'm
stumped.

-Jarrod

__________________________________
Do you Yahoo!?
Protect your identity with Yahoo! Mail AddressGuard
http://antispam.yahoo.com/whatsnewfree

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message