perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Schilling <rschill...@nationalinformatics.net>
Subject A TABLE-processing-with-[$ while $]-blocks-involved question
Date Sun, 14 Sep 2003 00:28:05 GMT
Just got done debugging an application that used the following form:

<TABLE WIDTH="100%">
<TR>
         <TH>Contract ID</TH>
         <TH>Start Timestamp</TH>
         <TH>End Timestamp</TH>
         <TH>Minimum Hours Quoted</TH>
         <TH>Maximum Hours Quoted</TH>
         <TH>Minimum Fees Quoted</TH>
         <TH>Maximum Fees Quoted</TH>
         <TH>Status</TH>
  </TR>
  [$ while @contractinfo=$rsmbacontracts->fetchrow $]
<TR>
         <TD>[+ $contractinfo[0] +]</TD>
         <TD>[+ $contractinfo[2] +]</TD>
         <TD>[+ $contractinfo[3] +]</TD>
         <TD>[+ $contractinfo[4] +]</TD>
         <TD>[+ $contractinfo[6] +]</TD>
         <TD>[+ $contractinfo[5] +]</TD>
         <TD>[+ $contractinfo[7] +]</TD>
         <TD>[+ $contractinfo[8] +]</TD>
</TR>
</TABLE>

[$ endwhile $]



The postgres log reported the following for the rsmbacontracts query:

LOG:  query: SELECT * FROM clientcontracts WHERE accountguid = 
'b6ea9cafe2d1997392d166b96e5697b1';
LOG:  pq_recvbuf: unexpected EOF on client connection


=======

I tried and tried to figure out what was wrong, and then it hit me: the 
[$ endwhile $] command needs to appear *before* the </TABLE> tag.

So, what happened?


I suspect it has to do with Embperl table processing, but am curious 
about the internals.

Richard Schilling
rsmba.biz

---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message