perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Winfield Henry <winfie...@rtelco.net>
Subject Re: check boxes
Date Sun, 21 Sep 2003 12:38:30 GMT
On Sat, 2003-09-20 at 20:22, Angus Lees wrote:
> At 19 Sep 2003 22:53:45 -0400, Winfield Henry wrote:
> > Yes, does that help/hurt matters?
> 
> > On Fri, 2003-09-19 at 06:53, Angus Lees wrote:
> > > At 16 Sep 2003 22:25:18 -0400, Winfield Henry wrote:
> > > > differently? One is using embperl 1.3.4 (not working) the other embperl
> > > > 2.0 (working). I have checked the fdat array on the 1.3.4 machine and
it
> > > > does contain a tab delimited array of the checkbox items, its just not
> > > > checking the boxes.
> > > 
> > > are you using perl 5.8 by any chance?
> 
> perl5.8 requires at least HTML::Embperl 1.3.5.
> 
> ("top posting" makes conversations very hard to follow)
> 
> -- 
>  - Gus
Ahha. I'd like to double check what is going on to be correct. 
On the machine with apache2.0/embperl2/perl5.8 I submit a form to itself with 
multiple checkboxes checked with the same fieldname, for instance, 

<form action="thisform.epl" method="POST" enctype="multipart/form-data">
<input type="checkbox" name="test" value="one">one<BR>
<input type="checkbox" name="test" value="two">two<BR>
<input type="checkbox" name="test" value="three">three<BR>
<input type="submit">
</form>

I check box 1 and 3 then submit the form to itself and boxes 1 and 3 are
still checked. BUT, on a machine with apache1.3.26/embperl1.3.4/perl5.8
the form comes back empty. Is this correct behavior? 

Sorry for the 'top-posting'. 

Thanks for the time

Winfield



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message