perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ckas...@eplsite.org>
Subject More testing of embperl 2.0b9
Date Thu, 03 Jul 2003 01:25:12 GMT
Hi all:

I continue testing embperl objects 2.0b9 and now i found that embperl is
closing mytables before i want close them.



This is my file base.eplo:

<html>
<head>
<title>Testing tables</title>
</head>
<body>
        [- Execute ({'inputfile' => 'page_header.eplo', escmode =>0}); -]
        [- Execute ('*') -]
        [-  Execute ({'inputfile' => 'page_footer.eplo', escmode =>0}); -]
</body>
</html>


In the file page_header.eplo i have this:

<center><b>This is my page header</b></center>
<table>
<tr>

In the file page_footer.eplo i have this:

</tr>
<table>

<center><b>This is my page footer</b></center>


And i have and index.eplo( this file is what i call from my browser) whit
just this line:
<td>left</td><td>center</td><td>right</td>



When i see the content(except my comments in capital letters) in my
browser, i see this:
<html>
<head>
<title>Testing tables</title>
</head>
<body>
        <center><b>This is my page header</b></center>
<table>
<tr>
</tr></table> WHY OF THIS CODE?

<td>left</td><td>center</td><td>right</td>

/tr CHARACTERS < AND > ARE MISSING
<table>

<center><b>This is my page footer</b></center>
</table> WHY OF THIS CODE?
</body>
</html>

As you can see, embperl is deforming the html code.

Somebody knows why of this?.

I apologies for the big content but it is to expline better my problem.

Thank you in advance

Carlos Kassab



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message