perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ckas...@eplsite.org>
Subject Re: more testing of embperl 2.0b9
Date Sat, 05 Jul 2003 21:09:20 GMT
Gerald:

Thank you for your help, now it is not closing my tables.

Carlos Kassab

> Hi,
>
> Embperl needs a proper nesting, for that reason it closes all open html
> tags which it processes. To avoid this problem,you can turn off
> processing of html tags with
>
> [$ syntax EmbperlBlocks $]
>
> and turn it on again
>
> [$ syntax Embperl $]
>
> Gerald
>
> --------------------------------------------------------------
> Gerald Richter     ecos electronic communication services gmbh
> IT-Securitylösungen * dynamische Webapplikationen * Consulting
>
> Post:       Tulpenstrasse 5          D-55276 Dienheim b. Mainz
> E-Mail:     richter@ecos.de          Voice:   +49 6133 939-122
> WWW:        http://www.ecos.de/      Fax:     +49 6133 939-333
> --------------------------------------------------------------
> |
> |   ECOS BB-5000 Firewall- und IT-Security Appliance: www.bb-5000.info
> |
> +-------------------------------------------------------------
>
> ----- Original Message -----
> From: <ckassab@eplsite.org>
> To: <richter@ecos.de>
> Sent: Thursday, July 03, 2003 3:27 AM
> Subject: more testing of embperl 2.0b9
>
>
>> Hi all:
>>
>> I continue testing embperl objects 2.0b9 and now i found that embperl
>> is closing mytables before i want close them.
>>
>>
>>
>> This is my file base.eplo:
>>
>> <html>
>> <head>
>> <title>Testing tables</title>
>> </head>
>> <body>
>>         [- Execute ({'inputfile' => 'page_header.eplo', escmode =>0});
>>         -] [- Execute ('*') -]
>>         [-  Execute ({'inputfile' => 'page_footer.eplo', escmode
>>         =>0}); -]
>> </body>
>> </html>
>>
>>
>> In the file page_header.eplo i have this:
>>
>> <center><b>This is my page header</b></center>
>> <table>
>> <tr>
>>
>> In the file page_footer.eplo i have this:
>>
>> </tr>
>> <table>
>>
>> <center><b>This is my page footer</b></center>
>>
>>
>> And i have and index.eplo( this file is what i call from my browser)
>> whit just this line:
>> <td>left</td><td>center</td><td>right</td>
>>
>>
>>
>> When i see the content(except my comments in capital letters) in my
>> browser, i see this:
>> <html>
>> <head>
>> <title>Testing tables</title>
>> </head>
>> <body>
>>         <center><b>This is my page header</b></center>
>> <table>
>> <tr>
>> </tr></table> WHY OF THIS CODE?
>>
>> <td>left</td><td>center</td><td>right</td>
>>
>> /tr CHARACTERS < AND > ARE MISSING
>> <table>
>>
>> <center><b>This is my page footer</b></center>
>> </table> WHY OF THIS CODE?
>> </body>
>> </html>
>>
>> As you can see, embperl is deforming the html code.
>>
>> Somebody knows why of this?.
>>
>> I apologies for the big content but it is to expline better my
>> problem.
>>
>> Thank you in advance
>>
>> Carlos Kassab
>>
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
> For additional commands, e-mail: embperl-help@perl.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message