perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "MaurĂ­cio Amorim " <masil...@terra.com.br>
Subject Embperl + Apache
Date Fri, 23 May 2003 17:08:29 GMT
Hi list, 

I finish an project using Embperl + Apache.

My configuration is:

Apache/1.3.27 (Unix) mod_perl/1.27 configured -- resuming normal operations
with Embperl 1.3.6 in SunOS 5.8

I use Apache::DBI with Oracle (persistent connection) and Apache::SessionX
using FileLock.

My problem is that,  many times the site stay slow and the apache logs:

[Fri May 23 13:18:09 2003] [warn] (22)Invalid argument: setsockopt: (TCP_NODELAY)
[Fri May 23 13:23:30 2003] [info] [client 10.202.12.137] (32)Broken pipe: client stopped connection
before rwrite completed

I did an truss in httpd process and when this page in embperl is submmited
the truss in any situations an show an signal SIGALRM 

signotifywait()                                 = 14
lwp_sigredirect(1, SIGALRM)                     = 0
    Received signal #14, SIGALRM, in read() [caught]
      siginfo: SIGALRM pid=8739 uid=4503
read(3, 0x003D34D8, 4096)                       Err#4 EINTR
sysconfig(_CONFIG_SIGRT_MIN)                    = 38
sigprocmask(SIG_SETMASK, 0xFF05DA50, 0x00000000) = 0
close(3)

My site use IFRAME tag (html 4.01) and many times,  two epl files are submmited
at "same time",  but i don't cancel it.

Anybody know what the problem for help-me ?

Exist any configuration for that problem or it is an problem in the network ?

This error occurr when no many requisitions are done for apache. 

Anybody have the same error some day ?


Thank you.
Mime
View raw message