perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Landwehr <andre.landw...@gmx.net>
Subject Empberl::Object on Apache 2
Date Sun, 30 Mar 2003 20:57:19 GMT
Hi,
I'm quite frustrated because I can't get Embperl::Object to work
with Apache 2. It does not accept any configuration directives.
I use Embperl from todays CVS. My setup is as follows:
LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
LoadModule embperl_module /usr/lib/perl5/auto/Embperl/Embperl.so
PerlModule Apache2
PerlModule ModPerl::RegistryCooker # <-- without this log_error()
                                         is not found ?!

When I try directives like 
EMBPERL_DEBUG 1
I get "Invalid command 'EMBPERL_DEBUG', perhaps mis-spelled or defined
by a module not included in the server configuration".
Unfortunately the same is true for every other directive,
including "Embperl_UseEnv On", which could have solved the
problem otherwise. I also tried to do a "PerlModule Embperl" in
addition to the LoadModule line, again without effect.

Normal Embperl (= non-Embperl::Object) pages work as expected, as
well as a minimal Embperl::Object application using only the
default values for every directive.

Any help is appreciated...

Andre

-- 
Any technology distinguishable from magic is insufficiently advanced.


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message