perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerald Richter" <rich...@ecos.de>
Subject Re: Problems when using require or modules..
Date Tue, 04 Mar 2003 15:34:34 GMT
>
> I have problems running latest stable and development version of Embperl
> when doing a require 'mylib.pl'; in the beginning of each embperl HTML
> file. What happens is that my own subroutines (Defined in mylib.pl) is
> sometimes working sometimes not.. I get the strange error:
>
> [Tue Mar  4 10:15:46 2003] [error] [12568]ERR:  24:  Error in Perl code:
> Undefined subroutine &Embperl::__1::getsql called at
> /home/kraftkallan/kraftkallan.com/admin/photogallery/manage.html line 110.
>

See
http://perl.apache.org/embperl/pod/doc/doc13/pod/Faq.-page-3-.htm#sect_19

>
> And finally, how is Embperl working with apache 2 and mod_perl 2 ?
>

It works fine in prefork mode (the default for Apache 2). Threaded MPM are
not supported yet. This means windows is not supported yet, because windows
only has a threaded mpm

Gerald

P.S. Please write further questions to the mailing list


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message