perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edouard Lagache" <lagac...@canebas.org>
Subject Thanks! Happy Camel! (Re: ModPerl registry woes?)
Date Sun, 16 Feb 2003 22:31:54 GMT
Thanks Randy and Gerald!

Finally, all obstacles are overcome and EmbPerl is running happy on 
<canebas.org>!  

Sigh, now I've got to convert all my static web pages! :-)

Peace, Edouard :-)

=========================================
Randy Kobes <randy@theoryx5.uwinnipeg.ca> wrote at Sun, 16 Feb
2003 13:00:41 -0600

>On Sun, 16 Feb 2003, Edouard Lagache wrote:
>
>> Dear EmbPerl veterans,
>> 
>> I'm still trying to get EmbPerl to cooperate with Mod_Perl
>> 1.99_08 and Apache 2.0.44.  Thanks to Gerald Richter, I got
>> past my compile error by using the CVS version, but now I can't
>> get past the test suite at the point it tried to fire up
>> Apache.  If I run the test suite unaltered - the error I get
>> is:
>> 
>>     Starting httpd...       [Sun Feb 16 09:33:51 2003] [warn] PassEnv
>>        variable ACTION_PREFIX was undefined                             
>>                                         
>>     [Sun Feb 16 09:33:51 2003] [error] Can't locate ModPerl/Registry.pm
>>        in @INC
>> 
>> Well, ModPerl/Registry.pm is actually in Apache2/ModPerl/Registry.pm. 
>> So, I tried making a symlink so that there was a ModPerl/Registry.pm. 
>> Alas, that has no effect.
>[ .. ]
>
>Try putting in a 'use Apache2;' in Embperl.pm, at around line 69,
>and also in test/conf/startup.pl, at around line 34, just around
>the parts where mod_perl 2 stuff is being pulled in.
> 
>-- 
>best regards,
>randy kobes
>
>
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message