perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edouard Lagache" <lagac...@canebas.org>
Subject ModPerl registry woes?
Date Sun, 16 Feb 2003 17:53:38 GMT
Dear EmbPerl veterans,

I'm still trying to get EmbPerl to cooperate with Mod_Perl 1.99_08 and
Apache 2.0.44.  Thanks to Gerald Richter, I got past my compile error by
using the CVS version, but now I can't get past the test suite at the
point it tried to fire up Apache.  If I run the test suite unaltered -
the error I get is:

    Starting httpd...       [Sun Feb 16 09:33:51 2003] [warn] PassEnv
       variable ACTION_PREFIX was undefined                             
                                        
    [Sun Feb 16 09:33:51 2003] [error] Can't locate ModPerl/Registry.pm
       in @INC

Well, ModPerl/Registry.pm is actually in Apache2/ModPerl/Registry.pm. 
So, I tried making a symlink so that there was a ModPerl/Registry.pm. 
Alas, that has no effect.

Undaunted (yet!) I decided to edit embperl/test/conf/startup.pl to change
ModPerl::Registry to Apache2::ModPerl::Registry.  That produces an even
more puzzling error message: 

    Starting httpd...       [Sun Feb 16 09:35:53 2003] [warn] PassEnv
       variable ACTION_PREFIX was undefined                             
                                        
    [Sun Feb 16 09:35:53 2003] [error] Base class package
      "ModPerl::RegistryCooker" is empty.                               
                                                   
    (Perhaps you need to 'use' the module which defines that package 
       first.) at /usr/lib/perl5/site_perl/5.8.0/
       i686-linux-thread-multi/Apache2/ModPerl/Registry.pm line
       11

Well, the file Apache2/ModPerl/RegistryCooker.pm isn't at all empty.  Nor
is  Perl complaining that it can't find the file RegistryCooker.pm .... so???

I see that, even if I didn't ask for it, mod_perl 1.99_08 installed the
files to permit mod_perl 1 compatibility. Is that the problem here?

Any Perls of wisdom are as always appreciated!

Peace, Edouard :-)


---------------------------------------------------------------------
To unsubscribe, e-mail: embperl-unsubscribe@perl.apache.org
For additional commands, e-mail: embperl-help@perl.apache.org


Mime
View raw message