perl-embperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruce G. Williams" <brucegil...@ev1.net>
Subject new Embperl person (read idiot) + Apache 2.0 + Win32 -> failed to resolve handler `Embperl'
Date Mon, 10 Feb 2003 15:22:23 GMT
Hello Wise Ones On The Hill,
    I have read all installation instructions for Embperl several times and followed them.
So many release changes, so many change notices....God I love it. 
   I am running Win32 + Apache Server 2.0.43 + mod_perl 1.99_09 + Perl5.6.1 + PHP 4.3.0 +
MySQL Server 3.23.54
   Everything *was* working fine until I tried to add Embperl.
   Right now, my Apache httpd.conf reads as follows:
---------------------------------
#
# Embperl section
#
<Files *.epl>
    SetHandler perl-script
    PerlHandler Embperl
    Options ExecCGI
</Files>
AddType text/html .epl
---------------------------------
My little simple.epl file is located in  {DOCUMENT_ROOT} (with +ExecCGI for now} and is as
follows:
---------------------------------
<HTML>
<HEAD>
    <TITLE>A Simple Embperl Document</TITLE>
</HEAD>
<BODY BGCOLOR="white">
<H2>A Simple Embperl Document</H2>
[- $time = localtime -]
<P>Here are the details of your request at [+ $time +]:</P>
<TABLE>
    <TR>
        <TH>Name</TH>
        <TH>Value</TH>
    </TR>
[# Output a row for each environment variable #]
[$ foreach $varname ( sort keys %ENV ) $]
    <TR>
        <TD><B>[+ $varname +]</B></TD>
        <TD>[+ $ENV{$varname} +]</TD>
    </TR>
[$ endforeach $]
</TABLE>
</BODY>
</HTML>
---------------------------------------
And I get a server error. Here is listing from Apache error log:
---------------------------------------
[error] failed to resolve handler `Embperl'
[Mon Feb 10 08:27:28 2003] [error] [client 127.0.0.1]
Can't locate loadable object for module Apache::Server in @INC 
(@INC contains: C:/Perl/lib C:/Perl/site/lib .) at C:/Perl/site/lib/Apache/XSLoader.pm line
16
Compilation failed in require at C:/Perl/site/lib/Embperl.pm line 69.
Compilation failed in require at (eval 2) line 3.
------------------------------------------
I have searched the Web for a solution but found none. I have searched the archives of your
site but found no help.
Be gentle with me, O Great Ones. Another source suggested I try "PerlHandler HTML::EmbPerl"
but this gives a similar
error. Please show me the way to the Promised Land, O Wise Ones.
Regards,
Bruce G. Williams

Mime
View raw message